0

I have Docker container within which NodeJS scripts are executed on schedule.

Scripts are executed every 10sec and after execution is done process list must be clear.

It works as expected on Minikube, Azure Container Service, Kubernetes on AWS EC2, -

enter image description here

..but on Google Kubernetes Engine when scripts are done they're still present in process list:

enter image description here

In script logs I can see that each attempt completed successfully and scripts logs and results are the same on every Kubernetes cluster I've tried.

I've tried all available versions of Kubernetes on Google but result is the same.

UPDATE1: issue can be reproduced not only on GKE, but also on GCE (regular VM)

UPDATE2: when I use node 6 or 7 instead of 8 issue can't be reproduced.

UPDATE3: deployments & executions were the same on all platforms, - simple deployment definition for Kubernetes and docker run -t %image%

Any ideas why it happens and how it could be fixed?

migrated from stackoverflow.com Mar 31 '18 at 11:38

This question came from our site for professional and enthusiast programmers.

  • I downvoted because you have not described how you're running the container. You can't expect people to guess. Is it through docker run? Is it through Kubernetes Pod deployment? Maybe the pods are still active and running, in that case of course the process will be still there. Please fix the question and I'll be upvoting this! – Ahmet Alp Balkan Apr 3 '18 at 0:45
  • Your question still doesn't make sense. You're talking about Kubernetes and docker run in the same question. If you're doing docker run, you are not using Kubernetes. :) – Ahmet Alp Balkan Apr 3 '18 at 17:51
  • Can you please give the full command? You've got to explain a LOT MORE on how to reproduce the problem. – Ahmet Alp Balkan Apr 3 '18 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.