1

I am trying to use Hyper-V to create a new virtual machine. To test it out I downloaded an Ubuntu 16.04 iso and headed on into the Hyper-V manager to create an instance. I have tried both Quick Create and the New Virtual Machine Wizard, but every time I try to create an instance I'm met with an error. My settings are quite basic, as shown in the following image:

enter image description here

When I attempt to create the instance I am given this very cryptic and non-helpful error:

enter image description here

I have tried all of the following:

  • Disabling and re-enabling Hyper-V windows feature
  • Double checking that virtualization is enabled in my bios
  • Switching between generation 1 and generation 2
  • Defining the OS iso before creation
  • Changing memory size and network settings
  • Running with elevated (admin) privileges
  • Changing the default location to another hard drive
  • Disabling all AV and Firewall protection temporarily
  • I checked to make sure my user is a member of the Hyper-V Administrator group
  • Drivers are up to date
  • Services window indicates that Hyper-V Virtual Machine Management is running (vmms)

I clearly have all Hyper V options enabled in windows features:

enter image description here

A check in my event viewer shows the error but provides no helpful information:

Source: Hyper-V-VMMS ID: 16010 Description: The Operation Failed.

I did notice this in there as well seperately, but I don't know what it means:

Source: Hyper-V-VMMS ID: 15350 Description: The virtualization infrastructure driver (VID) is not running

I'm not sure if that's the cause and, if it is, how to fix it (I'm pretty new to the whole Hyper-V side of things)

This is a little different from the standard error I see in Stack Overflow and across Google indicating permissions errors. I'm not really sure how to handle this. Any suggestions on what might be going wrong with this?

  • I am running a Ryzen Threadripper 1950X
  • 2x Vega64 cards

A quick SystemInfo check produces the following confirmation that my machine should be able to handle Hyper-V:

enter image description here

EDIT:

After disabling and re-enabling virtualization in my BIOS and turning off my computer completely then turning it back on I'm not getting the VID error anymore, but I am still unable to create virtual machines

  • Try run this command in CMD as admin - MOFCOMP %SYSTEMROOT%\System32\WindowsVirtualization.V2.mof This will rebuild the WMI components for virtualization. After it, try to restart The Virtual Machine Management Service via powershell - restart-service vmms . However, have you tried to create a VM without ISO? – Strepsils Apr 2 '18 at 14:40
1

Posible here is a solutuion - https://social.technet.microsoft.com/Forums/en-US/b810795c-a078-49a8-b584-9ac1e1b896d1/hyperv-failed-to-create-a-new-virtual-machine-a-required-privilege-is-not-held-by-the-client?forum=winserverhyperv

If you change the default setting for “Create Symbolic Link” on a Hyper-V Server you can get this error. This is due to the Virtual machines needing this right in order to link to the VHA storage areas. By default, when you install the Hyper-V role, a special group called "virtual machines" is created and given the “Create Symbolic Link” right. If you change this right with say a GPO (following a misguided STIG maybe?) you will not be able to create virtual machines and will get the above error. This group contains all the virtual machine Service SIDs.

Look here for more info; http://www.virtualizationadmin.com/articles-tutorials/microsoft-hyper-v-articles/storage-management/hyper-v-file-storage-permissions.html Check your restrictive policies GPO for this setting.

0

Another option is - https://www.reddit.com/r/HyperV/comments/56g0nq/failed_to_create_a_vm/d91mqg4

On a lark I changed the default folder for virtual hard disk files from F:\Hyper-V VMs\Virtual Hard Disks to C:\Hyper-V VMs\Virtual Hard Disks and the default folder for virtual machine configuration files from F:\Hyper-V VMs\Virtual Machines to C:\Hyper-V VMs\Virtual Machines.

After I did this I was able to create a VM. After I tested this I set the paths back to their original location on F: and tried again and was able to successfully create VM's. I'm guessing that Hyper-V was somehow confused internally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.