2

I have a series of drives that are are all encrypted with LUKS/dm-crypt. They are not all guaranteed to be plugged in at the time the system boots, but if they are, I would like to ensure they are mounted.

At the moment, I can specify the devices in /etc/crypttab, which will work if all the devices are present (it will prompt for the password, then decrypt and mount all the drives). However, if any drive is unplugged, the entire boot process will fail and it will fall back to emergency mode.

How can I specify that these drives should mounted as part of the boot process if present, without causing the entire boot to fail if a external drive is unplugged?

I am running Ubuntu 17.10 (Artful Aardvark) using systemd as init.

1

Add nofail to the options in the /etc/cryptab and /etc/fstab

https://www.freedesktop.org/software/systemd/man/crypttab.html#nofail

https://www.freedesktop.org/software/systemd/man/systemd.mount.html#nofail

1
  • Done that. In both. Still fails exactly as question describes: the two unwanted mount processes wait until timeout then boot fails to emergency mode. Anything else to try? – Jortstek Oct 23 '19 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.