1

Mine is Ubuntu 14 and I've enabled fpm-event with Apache.

apachectl -V | grep -i mpm shows:

Server MPM:     event

It seems those pages which take more than 30 seconds to execute I'm getting this error:

Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request.

Where should I change the configuration to increase it to day 45 seconds?

In the apache error log I can see:

[Tue Apr 03 16:14:44.259133 2018] [fastcgi:error] [pid 28646:tid 140666243819264] [client 103.52.51.21:60161] FastCGI: comm with server "/usr/lib/cgi-bin/php5-fcgi" aborted: idle timeout (30 sec), referer: http://www.example.com/google-analytics-charts/verify

Actually it is Drupal site which can be extremely slow.

1
  • What is your Timeout or ProxyTimeout directive set to? – ezra-s Apr 4 '18 at 8:33
1

Probably this solution helps you: https://stackoverflow.com/questions/40360922/increase-php-fpm-idle-timeout-setting

You can change idle-timeout in your apache config to extend it (cannot be 0):

FastCgiExternalServer /usr/lib/cgi-bin/php7-fcgi -socket /run/php/php7.0-fpm.sock -idle-timeout 1800 -pass-header Authorization

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.