Below are the different methods I tried to launch a custom AMI in Elastic Beanstalk but none seems to work.

  1. Launched the default Amazon AMI for PHP 7.0. Created a Ubuntu instance and installed all the required packages. Created an AMI from the Ubuntu instance and then changed the Beanstalk Platform AMI to that of the Ubuntu one. It showed success. Used eb deploy to deploy the application. Again it showed success. But the files have not moved to the instance.

  2. Tried the custom environments as provided in amazon docs (https://docs.aws.amazon.com/elasticbeanstalk/latest/dg/custom-platforms.html?icmpid=docs_elasticbeanstalk_console). However here I could not get the beanstalk url.

  3. Again I created an AMI using packer and tried to create a platform using eb cli. Though the platform is getting created but the beanstalk url is missing. Also here eb deploy does not deploy the application despite showing success.

I could not figure out the errors as in all the cases it is showing success but application not getting deployed. Also the Beanstalk url is missing when I create in from eb cli.

I am not sure where I am going wrong. Any help appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.