1

I am having trouble deploying a Task to all the workstations in my environment.

I am trying to setup a simple task that reboots at a specific time;

enter image description here enter image description here enter image description here

In my research on trying to accomplish this, I have created a basic task using NT AUTHORITY\SYSTEM as the user that applies this task.

I am trying to make this run regardless if someone is logged in or not though.

What I have noticed

The GPO applies, but the task never runs.

I can only view the Task in Task Scheduler if I run as Admin, but not as the local user.

I also noticed that the Task file is present in C:\Windows\System32\Tasks.

The task even has a "History" of running and succeeding (Much time in between) although I never saw it run.

My Environment

  • Windows Server 2012R2
  • Windows 10 workstation


Any help is appreciated.

Thanks!

  • How are you rebooting the client? Are you using a command or script? – wrieedx Apr 6 '18 at 1:21
  • Im using Shutdown.exe – Cheesus Crust Apr 6 '18 at 1:24
  • Enable the option "allow run on demand", then manually run it, what do you see? – strongline Apr 7 '18 at 18:23
1

Here, you have screenshot only of the General tab, while Triggers and Actions are more important. My guess is that you might be missing either the Recur every n days or Arguments for shutdown.

My similar, working GPO seems identical for the General settings, but I use GPO for shutdown and BIOS scheduler start for startup, since the goal is to shut them down for night and power them up early to get all the updates installed before the users arrive – these are computer classrooms.

Triggers
   1. Daily
      Stop task if it runs longer than
                             30 minutes
      Activate               [datetime]
      Enabled                Yes
      Recur every 1 days

Actions
   1. Start a program
      Program/script         shutdown
      Arguments              -s -t 300 -f

My arguments are trying to be as user friendly as they can, considering the needs:

  • Unless you have -f any unsaved data would cause the shutdown to abort. In this classroom case the computers needs to be freshly started in the morning, so it's ok, but be aware that this may cause losing data on employee workstations.
  • -t 300 warns the user 5 minutes before shutdown, to give time to save data. Useful with -f.
  • -s causes halt after shutdown, since I use BIOS or Wake-on-LAN for rebooting later. In your case you'd probably like to use -r for reboot, instead.

Also double check that you schedule the reboots when there isn't any installations or backups running as interrupting those may cause severe problems.

  • I've added more images. Thank you for the details, though I cannot seem to find the problem looking for the things you mentioned. – Cheesus Crust Apr 6 '18 at 14:17
0

I don't know if you've made any changes to the group policy task, but for troubleshooting purposes to make sure that those changes are forcefully applied to the client to try changing the action from "update" to "replace."

Also, you didn't supply any information from your actions tab. Check that the shutdown executable exists on the client. Check that you've supplied the appropriate arguments to the shutdown command in the arguments field such as /r to reboot. If something is preventing the client from rebooting you may need to add /f to induce a forced reboot.

0

In the "General" tab, can you check "Run only when user is logged on" please ?

This is an issue, and the GUI shouldn't let you check "Run whether user is logged on or not" when you select the System account but there is a bug in this GPP UI.

However, since the System account is selected, your task will run even if nobody is logged on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.