4

We are preparing to move to Windows 10, and one application, which works fine on Windows 7, does not behave correctly in a normal user session. The application is no longer supported by the vendor, so we have no escalation path for support.

We can get the application to behave correctly by using [Run as different user], and re-entering the same credentials as the current user's session. Using the RUNAS command line also works.

Neither [Run as Administrator], nor logging on as a local administrator, resolves the issue, so this doesn't seem to be a Windows permissions issue (I'm yet to be convinced this is a UAC issue).

As the app currently is called from a script, we are OK with using the command line, but don't want the user to need to re-enter their password unnecessarily.

To troubleshoot, I tried to use ProcMon, and found nothing obvious.

My questions are:

  1. How does Windows treat [Run as different user]/RUNAS.exe differently from the current session, so we can try to emulate it?

  2. Is there a local security item which I can do to emulate the above?

  3. What other methods can I use to troubleshoot the exact issue?

TL:DR Damn you Windows 10, allow my app to work!

0

I have just some suggestion:

  • Have you tried to disable the UAC? Does it make any difference?
  • Have you tried to disable the antivirus?
  • Have you tried to uninstall the antivirus? (disabled antivirus, sometime, are not really disabled...)
  • Have you tried the same executable on a different computer? (sometime software works differently between different computers, without obvious reason (I know that there is always a reason, but sometime finding the reason require too much time/expertise...))
  • Have you tried to mess with the 'compatibility options' of the executable properties?
  • Have you tried to copy the executable folder, and execute the copy instead that the original one? (I know it's crazy, but I've seen this work. Clearly something was wrong on the file security descriptor or something... and taking ownership of all the files/folder wasn't making a difference)
  • Does the VB6 executable use any .Net DLL? in latest version of .Net (4.6 if I remember correctly) Microsoft moved certain classes from DLL to another, so there are situation where a VB6 software that use .Net DLL works with .net 4 Framework, but doesn't works on .Net 4.6 (even if it should be compatible...)
  • Have you tried to unplug the computer? (not a restart, but a real unplug/forced reset, because Windows 10, usually, when you restart it, doesent restart everything, but keep some state from previous execution to start faster (you can search for Windows 10 fast startup))
  • Have you tried on a clean Win 10 installation? Maybe on a virtual PC? (so you can mess with updates, tool, software...)
  • Thanks for the thoughts, so there are some which I will need to try. - UAC; some elements are already disabled on the SOE - A/V; No and No - maybe a last resort as it will run correctly when using RUNAS processing. - Different/New computer image; It is reproducible on all SOE image machines - Compatibility; like crazy we tried all options we could think of. - VB6 and .Net; There are no links to .Net binaries or DLLs, and this would prevent it working at all for the user or on the machine. With RUNAS is that there is no GPO processing, so we tried eliminating GPOs without resolving. – Geoff Apr 11 '18 at 23:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.