I tried to make a DNS trace request (taking Oxford's website www.ox.ac.uk as an example) starting from Google's DNS I can successfully get the result and the route was via the country level DNS nsa.nic.uk.

However, when I tried to ask nsa.nic.uk directly, there is no route shown. Is that normal and why didn't it show the result?

Thanks in advance!

Command 1 (asking Googld DNS):-

$ dig +trace www.ox.ac.uk @

Command 1 Result (get route successfully):- (Google DNS)

-> (e.root-servers.net)

-> (nsa.nic.uk)

-> (ns4.ja.net)

-> (ns2.ja.net)

-> (www.ox.ac.uk)

Command 2 (asking nsa.nic.uk directly):-

$ dig +trace www.ox.ac.uk @

Command 2 Result (get no route):-

Received 28 bytes from in 79 ms


Yes, this is normal.

Google DNS is a "recursive" DNS, which means it will resolve any domains for you (by querying the consecutive authoritative DNS servers for each of the components of the domain, starting with the root and going all the way to the "www" component.)

The country DNS nsa.nic.uk is an authoritative DNS for "uk." but it does not accept recursive queries.

If you do the "dig" command without +trace, you'll see it will reply something, but it's only the next level of the tree:

$ dig www.ox.ac.uk @
ac.uk.          172800  IN  NS  ns3.ja.net.
ac.uk.          172800  IN  NS  ns4.ja.net.
ac.uk.          172800  IN  NS  ns2.ja.net.
ac.uk.          172800  IN  NS  ns1.surfnet.nl.
ac.uk.          172800  IN  NS  dns-3.dfn.de.
ac.uk.          172800  IN  NS  ns0.ja.net.
ac.uk.          172800  IN  NS  auth03.ns.uu.net.

If then you go to the next step and ask one of those for the domain, you'll get the next step:

$ dig www.ox.ac.uk @ns0.ja.net
ox.ac.uk.       86400   IN  NS  dns1.ox.ac.uk.
ox.ac.uk.       86400   IN  NS  dns2.ox.ac.uk.
ox.ac.uk.       86400   IN  NS  dns0.ox.ac.uk.
ox.ac.uk.       86400   IN  NS  ns2.ja.net.

When you query, it does all the steps of the resolution for you... And when you do +trace, it will show you the individual steps too...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.