1

We have an application with ColdFusion 8 (the latest official release fully updated) in unix environment that the CPU sometimes goes up to 99%.

Sometimes it takes days, and other times it takes minutes. We also using hibernate to the business logic.

We've tried to remove all template cache and desactivate storage mechanism for client sessions (according to this info from Adobe) in coldfusion.

Nothing worked. When we desactivate template cache it only take 2 hours to go up to 99% of the CPU.

Any suggestions? All will be HIGHLY appreciated.

Thanks in advance.

2

Reasons can be really-really different. Once I had a dumb eternal while-loop in simple model.

Think Fusion Reactor is what you need. It helped me to resolve the very similar issue.

  • We are using hibernate to the business logic. Fusion Reactor gives all the info about methods, classes, connections to the DB and transactions? It's free to use? Thks Sergii! – lfbn Dec 4 '09 at 17:16
  • Their website gives really detailed description of the product details. As for price, they provide free trial period for 10 days, this can be enough to resolve some issues and also make sure that product is useful for you. – Sergii Dec 5 '09 at 21:15
0

This answer is usually something I only give on SO but profile! Make sure it's not some type of memory, thread, handle, or file leak going in your application. If you can verify it's not your application then I would escalate this for seeking support from Adobe especially if you can show them from your profiling results that the leak is occurring in their domain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.