-1

We installed Zabbix very recently in our environment and we are adding our servers and services. At first there was no problem but right now we encountered with partially collected data and a graph resulted like below.

What do you think the problem could be ?

Edit: Problem started after we add new items and server. Obviously Values processed by Zabbix becomes more than 6.

Edit 2: Added Zabbix poller busy rate graph and CPU load values

Edit 3: Added MariaDB CPU load graph, which is almost 0

SQL database logs Values processed by Zabbix

After incresing the starter poller count

Zabbix Load 1,5,15 Values processed by Zabbix & Busy pollers

Current MariaDB Load Graph enter image description here

  • Is the server too busy to run the agent? – Michael Hampton Apr 9 '18 at 19:34
  • I dont think so. According to Zabbix Server itself it has %98 idle cpu. Also it is interesting that Zabbix Server CPU data is also inconsistent. – Harun Baris Bulut Apr 9 '18 at 19:38
  • How's the database doing? Maybe it has too low maximum connection limits / connectivity issues to database / something similar? – Janne Pikkarainen Apr 10 '18 at 6:59
  • Database is running on another VM and I have added the load for database VM, which is almost 0. – Harun Baris Bulut Apr 11 '18 at 7:51
1

This is a general performance issue, and impossible to answer directly. Nevertheless, you might want to look into the following:

  • assuming you are using passive items, check internal monitoring (included in the default Zabbix server template) for poller process busy rate; if they are very busy, increase the poller count (but if this happens with a small number of items, first investigate why item polling is this slow)
  • also check internal monitoring for all other processes, notably checking the busy rate of the database syncer processes; if you see some process being very busy, it could be related to the data collection issues you are seeing
  • check the server logfile - does it show connection failures? If so, the issue might be on the agent side where you might either need more agent processes (configurable in the agent config file), or investigate why items are slow

Your latest edits show even the internal items missing data, thus we can completely rule out the agent. Also check the server logfile for database-related errors.

  • I also do suspect from performance issues, that is why I increased the number of pollers as you said but the result still the same. I will be adding new data to the post. – Harun Baris Bulut Apr 10 '18 at 2:22
  • The new data shows even internal items missing values. I've expanded on that a bit in the answer. Please also see all other questions/suggestions I have listed. – Richlv Apr 10 '18 at 6:46
-1

It turns out that the problem was on the database side. I still dont know how it happenned however some insert queries did not worked.

We have reset and reinstall database and the problem is solved.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.