I can't access my local printers with \\\printername. Windows XP gives me an error message in my language which roughly translate to :

"Impossible to complete this operation. You have entered a wrong printer name or the specified printer is not connected to the server anymore."

I can't access my pdf printer either through the localhost share.

I can access all of them by specifying my computer name instead of

The source of the problem must be this : I installed Microsoft Loopback Adapter. Found out it wasn't usefull and uninstall it. Localhost stopped working correctly sometime after that.

My folder shares seems to work out fine but I don't want to take any chances.

Rebooted, Didn't help.

As a demand, here's a (translated as best I can) printout of the "route print" command :

Adapters List
0x1 ........................... MS TCP Loopback interface
0x2 ...00 50 56 c0 00 08 ...... VMware Virtual Ethernet Adapter for VMnet8
0x3 ...00 50 56 c0 00 01 ...... VMware Virtual Ethernet Adapter for VMnet1
0x4 ...xx xx xx xx xx xx ...... Intel(R) PRO/100 VE Network Connection
Active routes :
Destination          Mask           Addr. gateway    Adr. adapter   Metric       20       20       20       20       1       20       20       20       20       20       20       20       20       20       1       1       1
Default Gateway :
Persistants routes :

I have hidden my mac address for security reasons.

  • Please go to a command prompt (Start -> Run -> cmd). Then type "route print" (without quotes) and post the output as an edit to your question. – Scott Lundberg Dec 3 '09 at 16:31
  • Just add it back into your hosts file. – John Gardeniers Dec 4 '09 at 1:06
  • I tried editing the host file entry. I can write whatever I want there it doesn't change anything. – Philippe Carriere Dec 4 '09 at 14:47

Have you tried System Restore?

| improve this answer | |
  • Do you mean System Restore? – Scott Lundberg Dec 3 '09 at 16:29
  • I didn't try System Restore. Which operation in System Restore do you suggest ? – Philippe Carriere Dec 3 '09 at 18:15
  • Just reset you system state to previous date, when everything worked fine. – TiFFolk Dec 3 '09 at 18:28
  • I did other changes since then. So I had another choice, I'd rather try the other one. – Philippe Carriere Dec 3 '09 at 21:37
  • System Restore deactivated. Solves my dilemma. – Philippe Carriere Dec 4 '09 at 14:58

Ok, so is, I'm assuming, your "main" physical address with the 192.168. addresses as the VMnet1 & 8. \\ doesn't work but \\machinename does.

Have you turned off the Server service?

| improve this answer | |
  • is my main address. The VMware addresses are used by my virtual machine and should be harmless. Are you asking me to turn off the server service or asking me if it's off ? The server service is started. – Philippe Carriere Dec 3 '09 at 21:35
  • I'm actually just trying to understand what service governs the localhost response on a windows box...it's been a while since I've had to run one. It would be a lot simpler if you just had an Lo0 interface that showed up or down... – Greeblesnort Dec 5 '09 at 4:47
  1. try to renew your IP with

    ipconfig /release
    ipconfig /renew
  2. try to delete this route    


    route delete

    and add a new one

    route add mask
  3. try to flush old DNS information with

    ipconfig /flushdns
  4. try to enable Loopback adapter back and check

  5. check the hosts file

| improve this answer | |
  • 1 - Renewed ip. Nop. 3 - Tried deleting the route. It can't delete it because it can't find it... stupid MS ? 4 - Flushed the DNS. Nop. 5- Reinstalled MS adapter. Nop. Checked the host file. Same as any host file. – Philippe Carriere Dec 4 '09 at 14:46

just out of curiosity have you tried to reinstall the tcp/ip stack on the machine? do you have another machine to try ? Another thing to point out is this-you are in a 127 address bloc and it's easy to get screwed up there.Move things over if you have to.

  • I reinstalled the TCP/IP stack with the following command : netsh int ip reset resetlog.txt. Din't change anything (to my problem). I don't understand the last part of your answer about the 127 address bloc. However, I'm pretty sure I can't do anything about it since the network is managed my company's technician (who is pretty much clueless about my problem). – Philippe Carriere Jan 15 '10 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.