0

Very new to Linux and currently tasked to install tomcat 7 in centos 7 os.

I followed the instruction in How To Install Apache Tomcat 7 on CentOS 7 via Yum. Everything seems to be ok and did not get any errors but as soon as I run

sudo systemctl status tomcat

It shows that the tomcat.service is Active: Inactive (Dead).

I opened the catalina.out to see error messages but it is not showing any error. Would appreciate any help to nudge me to the right direction.

0

I strongly recommend removing the admin package once you've got it running. It's a pretty big security risk.

What does /var/log/tomcat7/catalina.out tell you? What does journalctl -u tomcat7 give you? java -version? Is something else already listening on port 8080?

Finally, have you tried undoing the customizations from the walkthrough? If the defaults work it could be a fat finger or other misconfiguration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.