1

Can I run a newer Windows Server OS on an old server equipment that is not supported? I want to know because I have a Dell PowerEdge 2900 and I have a full copy of Windows Server 2016 Standard. I want to know if its possible.

  • 2
    How about you try it? – Spooler Apr 17 '18 at 4:02
  • Give it a go. But hopefully someone else is paying for your electricity! – Michael Hampton Apr 17 '18 at 4:15
  • well i tried and it boots up but it does not detect any hard drives – Eric Apr 17 '18 at 4:16
  • 1
    I was able to install Sever 2016 on a Dell 2950, however it would not run hyper-v or the containers, due to the Intel processor limitations. – Anthony Fornito Apr 17 '18 at 14:32
  • Forget the USB method to install it by the way, the ISO on a USB key need an UEFI bios to run because of the size (5.5G). So a double layer DVD only, or via the DRAC. – yagmoth555 Aug 20 '18 at 17:47
2

Dell's official stance is it isn't supported. http://www.dell.com/support/home/us/en/4/drivers/supportedos/poweredge-2900

The latest version of Windows Server they support on the 2900 is Windows Server 2012 R2.

  • 1
    oh OK so if a OS is not supported can that affect driver issues. – Eric Apr 17 '18 at 4:55
  • Yes. With the hardware you have, run supported Window Server OS and latest supported drivers to get stable system performance. – A.Newgate Apr 17 '18 at 12:00
-1

God is there just to provide blessings. Rest everything had to be created and maintained by humans.

Yes. It is possible to run Windows 2016 Server OS on older systems like Dell PowerEdge 2900.

Let me share our research with you. We had installed and tried, successfully, 2016 server DC edition on two older servers, one without the supporting processor (on IBM x3550 7978) for EPT and another with supporting processor (Dell R310) for EPT (as per MS documentation). This is purely for research only and not part of our enterprise network.

How to:

  1. IBM x3550 type 7978 (Xeon E5345 x 2 (2.53GHz), 32G RAM, 4x146G SAS)

    • The processor supports virtualization but doesn't have SLAT / EPT
    • Configured RAID, as usual
    • Clean install from USB - completed without any issues.
    • Configured server roles - HYPER V not supported.
    • Windows update - very smooth, ran in back ground for about one hour, wanted to restart multiple times.
    • Containers - Configuration, networking and monitoring of Windows 2016 core, IIS and a Nano server - completed smoothly.
    • Special note - Did not hang anytime during the installation / configuration. Total time taken is around 5 and half hours.
  2. Dell R310 (Xeon x3450 x 1 (2.53GHz), 8G RAM, 3x1T +1x2T SATA).

    • Configured RAID, as usual.
    • Booted from USB – did not detect the hard drives at all.
    • Tried the System Configuration (F10). Asked for drivers and refused the drivers from the CD (made from downloaded files of Dell).
    • Changed the RAID configuration by setting all disks to non-RAID.
    • Did not boot from the USB directly. Had to select HDD-USB from the boot menu (F9). Ignoring all critical messages proceeded with the installation. Did not detect any hard drives.
    • In Bios, changed the boot option from RAID to ATA and proceeded with installation from USB. Viola, it had detected all 4 HDDs and recognized them as Primary drives and can’t install on any of them. I had deleted all of them and installed on one of the drives.
    • After rebooting, as part of the installation, a message came up saying ‘there was a critical error in the disk configuration. Press F1 to continue, F2 to system setup.’ Proceeded with F1. This was repeated at every reboot, which means you can’t use this server in a data center where the rebooting has to take you to OS level without human intervention.
    • I’d removed cables to HDDs, changed FVS jumper from test mode (2-3) to default (1-2), reconnected HDD cables and rebooted. Booted directly to OS without any messages.
    • Another pain in the form of Windows updates. 3 updates started, 6% downloading for over 3 hours. Rebooted and found 2 updates already installed and third (KB4013720) failed. Tried for 2 more hours without any result. Setting Windows defender to off also did not help.
    • Changed Windows update service in Services from Automatic to Manual and stopped the service. Switched off Windows defender, manually downloaded the updates from catalog.updates.microsoft.com. Started Windows update service and installed updates one by one. Apart from the failed one, there were several more updates all installed within 40 minutes (add download time of another 10 minutes).
    • Stopped Windows Update service.
    • Added Hyper-V successfully. Checked the functioning of few VMs and found working.
    • Time taken – 3 working days completely (1 day only devoted to trouble shooting of Updates)

Time to celebrate !

  • This is not hack. However, it is surprising to get a negative vote, whoever had voted, despite mentioning that we are sharing our research. It would be worth appreciating if people whoever down voted may kindly and courteously post a comment with a reason for down voting. – IITC Aug 22 '18 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.