0

I have HP Ethernet 1Gb 4-port 331i Adapter - NIC installed on my machine and when I configure IP addresses for the ports/NICs, I get answer from only 1st port/NIC and other 3 ports/NICs do not respond. I tried with DHCP config & static but no avail, appears as if I am missing very basic thing, please see my config as follows

ubuntu@ubuntu:~$ lsb_release -a 
No LSB modules are available.
Distributor ID: Ubuntu 
Description:    Ubuntu 16.04.4 LTS
Release:        16.04 
Codename:       xenial

Here is my configuration file /etc/network/interfaces with first port/NIC as static & others IP addresses from DHCP.

$vi /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eno1
iface eno1 inet static
address 10.1.10.165
netmask 255.255.255.0
gateway 10.1.10.1
dns-nameservers 125.15.15.15 175.175.176.176

auto eno2
iface eno2 inet dhcp

auto eno3
iface eno3 inet dhcp

auto eno4
iface eno4 inet dhcp

In this configuration I get IP addresses from DHCP fine but when I try to connect to them they do not work, only eno1 works. For other 3 I can't even PING them from outside and only static is working. This is what I get from ip a command

ubuntu@ubuntu:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 94:18:82:02:c1:98 brd ff:ff:ff:ff:ff:ff
    inet 10.1.10.165/24 brd 10.1.10.255 scope global eno1
       valid_lft forever preferred_lft forever
    inet6 2603:3023:101:ec00:9618:82ff:fe02:c198/64 scope global mngtmpaddr dynamic
       valid_lft 345598sec preferred_lft 345598sec
    inet6 fe80::9618:82ff:fe02:c198/64 scope link
       valid_lft forever preferred_lft forever
3: eno2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 94:18:82:02:c1:99 brd ff:ff:ff:ff:ff:ff
    inet 10.1.10.72/24 brd 10.1.10.255 scope global eno2
       valid_lft forever preferred_lft forever
    inet6 2603:3023:101:ec00:9618:82ff:fe02:c199/64 scope global mngtmpaddr dynamic
       valid_lft 345598sec preferred_lft 345598sec
    inet6 fe80::9618:82ff:fe02:c199/64 scope link
       valid_lft forever preferred_lft forever
4: eno3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 94:18:82:02:c1:9a brd ff:ff:ff:ff:ff:ff
    inet 10.1.10.74/24 brd 10.1.10.255 scope global eno3
       valid_lft forever preferred_lft forever
    inet6 2603:3023:101:ec00:9618:82ff:fe02:c19a/64 scope global mngtmpaddr dynamic
       valid_lft 345598sec preferred_lft 345598sec
    inet6 fe80::9618:82ff:fe02:c19a/64 scope link
       valid_lft forever preferred_lft forever
5: eno4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 94:18:82:02:c1:9b brd ff:ff:ff:ff:ff:ff
    inet 10.1.10.75/24 brd 10.1.10.255 scope global eno4
       valid_lft forever preferred_lft forever
    inet6 2603:3023:101:ec00:9618:82ff:fe02:c19b/64 scope global mngtmpaddr dynamic
       valid_lft 345598sec preferred_lft 345598sec
    inet6 fe80::9618:82ff:fe02:c19b/64 scope link
       valid_lft forever preferred_lft forever

I also tried with my configuration file /etc/network/interfaces where all ports/NICs as static but still only first one eno1 responds from inside or outside and all other 3 ports/NICs do not respond, see config file

$vi /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eno1
iface eno1 inet static
address 10.1.10.165
netmask 255.255.255.0
gateway 10.1.10.1
dns-nameservers 75.75.75.75 75.75.76.76 8.8.8.8 1.1.1.1

auto eno2
iface eno2 inet static
address 10.1.10.66
netmask 255.255.255.0

auto eno3
iface eno3 inet static
address 10.1.10.67
netmask 255.255.255.0

auto eno4
iface eno4 inet static
address 10.1.10.68
netmask 255.255.255.0

Can someone please guide me where I am wrong and unable to connect on other 3 IP addresses of other 3 ports/NICs

FYI: I have made sure that there is no firewall on Ubuntu server and physical connectivity is fine.

1

It looks like you're trying to use all four NICs on the same subnet. Unless you bond them (in which case they become one logical NIC anyway) you can't do that.

If you want to test, bring just one interface up at a time.

If you're trying to achieve something particular, please tell us.

  • OK, so if I wan to bond eno1 eno2 eno3 into one how can I? I tried following this but bonding does not work, and unable to restart networking service. – Farmi Apr 23 '18 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.