1

I have a couple of new servers I'm testing for a customer... We've brought them into the mix of 'Host Servers' for the Remote Desktop Services collection and we've set 'Allow new connections' to 'False' for both of the new servers.

Users have since logged in and had their session created on the new servers!

This is an issue because we've got further installations of software to perform and reboots to carry out etc that we simply cant do on production servers.

Why would it not be listening to the 'Allow New Connections' property?

Any help appriciated.

1

Can you check this registry value on one of the Session Host server? :

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server => TSServerDrainMode

If the value of this registry key is 0, can you try to set "Allow New Connections" to True, then to False again and check this registry key value again ? It should be 1 (but don't change it manually in the registry !)

There is a bug in the management interfaces (either Server Manager or PowerShell cmdlet), if you set this value to False before adding your RDSH to a collection, then this value is not honored.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.