0

I have an associate who has the following server configuration:

Microsoft Windows Server 2008 R2 Standard – Version 6.1.7601 Service

Pack 1 Build 7601 Internet Information Services (Version 7.5.7600.16385)

MySQL Workbench 6.3 – Version 6.3.8 build 1228 CE (64 bits)

PHP Version 5.4.22

phpinfo() shows openssl 0.9.8y

It seems openssl 0.9.8y does not support TLS 1.2 . Can anyone provide instructions on how to upgrade openssl0.9.8y to a more recent version that supports TLS 1.2 under the windows environment mentioned above? I've heard some people say that upgrading to PHP 5.6 can automatically upgrade openssl as well. I want to do whichever is easier.....either upgrading PHP to 5.6, or upgrading openssl only. Any instructions available?

Thanks

  • 1
    Well, you desperately need to get rid of both of them, because they're long past end of support. – Michael Hampton Apr 23 '18 at 5:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.