0

When using the Dymo Labelwriter javascript to print via the service on https://localhost:41951/DYMO/DLS/Printing/PrintLabel, the debugger shows it takes around 16 seconds for the call to print the label and return "true". The same for the RenderLabel call.

This happens on both Chrome and edge, current versions on windows 10.

I've reinstalled the labelwriter software to the latest version.

The strange thing is that this happens on two machines, but on a third the printing is done in about 500ms. All (afaik) are up to date on updates.

10
  • Perhaps the printer drivers haven't been installed correctly? Did you reboot the problematic systems? Apr 23, 2018 at 10:33
  • The printer prints immediately from the Dyno label program, so the printer is fine, it is the print server on 41951 being slow.
    – Lenne
    Apr 23, 2018 at 10:47
  • Is the "Dyno label program" running on the same systems? Anything in the event logs about the print server? Apr 23, 2018 at 10:50
  • The "Dymo lapel program" is the one which can be downloiaded from the dymo site, and yes, it is running on the same machine which is slow on printing labels from the web via the dymo service on port 41951
    – Lenne
    Apr 23, 2018 at 11:04
  • other calls to the dymo printservice like localhost:41951/DYMO/DLS/Printing/GetPrinters works in 10ms.
    – Lenne
    Apr 23, 2018 at 11:12

1 Answer 1

0

This was severely limiting a client's ability to do business so I broke out Procmon and got to the bottom of this.

It appears to be due to the Dymo Label Service querying 128.30.52.100 (hans-moleman.w3.org) every time it was fed a label to validate its schema. We were not being rate limited by this service until today.

Setting an outbound firewall rule against this IP address for the DLS service executable fixed the issue.

3
  • CAN YOU CLARIFY THE ANSWER? What did you do in the firewall? Block the address? redirect it? I am having the same issue here. Thought it had something to do with TLS
    – John C
    Apr 24, 2018 at 3:09
  • Try the following powershell command New-NetFirewallRule -DisplayName "dymo-xsd-exclude" -Direction Outbound -Action Block -Program "C:\Program Files (x86)\Dymo\DYMO Label Software\DYMO.DLS.Printing.Host.exe" -RemoteAddress 128.30.52.100 If that doesn't work create a global outbound rule for the same IP. Here's a generic guide. Apr 24, 2018 at 22:57
  • Dymo is aware of the issue: developers.dymo.com/2018/04/24/recent-issues-with-slow-printing
    – Lenne
    Apr 25, 2018 at 8:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.