0

I have VM-Instances, working well with ubuntu 16.04, LAMPP and Wordpress since Dec 2017.

But since yesterday 25/04/18, when I was building wordpress in wp-admin, suddenly Wordpress gave error message "Error establishing a database connection". Immediately I checked GCP-console and access ssh. I suspect there was a problem with mysql (before this ever happened), so I rebooted the server and the server returned to normal, but only a few minutes. Then a database connection error occurs again. This time when I access SSH via console, it always comes out error message

"Connection Failed - An error occurred while communicating with the SSH server. Check the server and the network configuration".

If I open the website was always out message "This site can not be reached". I've tried checking firewall configurations etc, but did not find any weirdness (because I did not make any changes).

so from yesterday to today, I can not access server in browser or via SSH. Server down / offline.

How to solve a suddenly problematic server like this?

Thanks.

  • Try to ssh with -vvv flags and post the output (remove usernames, IPs and so on before posting). Do you have any other means for accessing this VM? My guess is that your root (/) filesystem is full. – Daniel Apr 26 '18 at 11:26
  • sorry, I can't accessing this VM. Do you have any suggestions for doing this? – Kukuh Ariyuswanto Apr 27 '18 at 10:46
  • debug2: ssh_connect_direct: needpriv 0 debug1: Connecting to XXX [XXX] port 22. debug1: Connection established. debug1: identity file /home/XX/.ssh/google_compute_engine type 1 debug1: key_load_public: No such file or directory debug1: identity file /home/XX/.ssh/google_compute_engine-cert type -1 debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_7.4p1 Debian-10+deb9u3 ssh_exchange_identification: read: Connection reset by peer ERROR: (gcloud.compute.ssh) [/usr/bin/ssh] exited with return code [255]. – Kukuh Ariyuswanto Apr 27 '18 at 15:51
  • Did you check the Disk size? I have had problems with SSH in the past where it cannot assign the tmp session file because of lack of space – Diego Velez Apr 9 '19 at 16:26
0

so from yesterday to today, I can not access server in browser or via SSH. Server down / offline.

How to solve a suddenly problematic server like this?

Apart from having regular ssh, you should have console access to google cloud platform. (Console access is a sort of emergency/maintenance backdoor ) .If you don't have access to google cloud platform, ask for the person who created the vm for you.

if the vm is down start it,

 1. Go to the Google Cloud Platform Console. Open the console left side
 2. menu and select Compute Engine. On the left, select VM Instances.
 3. Select the checkboxes next to the instances that you want to start,
    and then click the Start button.

more. https://cloud.google.com/billing/docs/how-to/restart-services

console access etc https://cloud.google.com/compute/docs/instances/connecting-to-instance

Support Options https://cloud.google.com/support/

| improve this answer | |
0

You could use the serial console, this would need to be enabled.

Edit the VM:

Remote access Enable connecting to serial ports

https://cloud.google.com/compute/docs/instances/interacting-with-serial-console?hl=en_US

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.