1

Noticing none of the settings in an ESXi 6.7 installation are surviving reboot.

I created the USB with a stock installation ISO like always, downloaded from the VMWare website. Just used the USB key like a normal drive. Have been doing this for several years now. Been using ESXi since version 5.5.

Have had a FreeNAS VM with the SATA controller on a Supermicro X9SCL-F passed through the whole time, too.

I upgraded (via new install) to 6.7 tonight. I toggled the SATA controller to passthrough, reboot. Upon reboot, passthrough disabled.

I thought maybe it was the fault of the VMKernel.boot.disableACScheck = false flag, so I set it to true. Reboot, flag set to false again.

I tried setting a VM to autostart. Reboot, VM not set to autostart anymore.

That's when I noticed -- none of the settings are surviving a reboot.

Now I've set boot.cfg to include the following:

kernelopt=autoPartition=TRUE skipPartitioningSsds=TRUE autoPartitionCreateUSBCoreDumpPartition=TRUE

Settings still appear not to be persistent.

During boot I'm seeing the following regarding passthrough:

method invocation failed: pcipassthrough->start() failed: error while executing the cli

Does anybody know what's going on? This is really frustrating. I've been struggling with it for hours.

  • I am using VMWare Worktstation 14 and I recently have been a similar problem where settings are not being saved – Forethinker Jul 14 '18 at 0:20
0

I wanted to follow-up on this and how I got it solved:

Well, not sure I really solved the issue itself, I just gave up on the whole thing.

I re-installed ESXi by getting the 6.7 ISO and using ESXi to make fresh boot USBs for my three servers - something about running the updates wasn't taking, especially with one system in particular I had asked about, the X9SCL-F, which I noticed in the HCL hasn't officially been supported since version 5.1.

Wish I had figured out what the issue was and devised a function to solve it, but my guess is there were lots of issues culminating and I should feel lucky that it runs on my old servers at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.