1

I have a laptop with Windows 10 and a Realtek PCIe GBE Family Controller. My NIC is connected to a switch in trunk mode (traffic for 2 VLANs transiting via this connection).

I would like to setup the VLANs on an Ubuntu Linux VM on Virtual Box.

First, I created two VLANs on Windows via the Realtek diagnostic utility.

The Ubuntu VM will act as a DHCP server for the two VLANs (everything is set up with isc-dhcp-server). I also did all the necessary configuration on Ubuntu for the VLANs i.e. creating the VLANs, configuring IP addresses etc...

On Virtual Box, I only have one virtual adapter configured in bridged mode and using the Realtek NIC.

When I run Wireshark on Ubuntu to capture traffic, I don't see any incoming traffic for the VLANs.

Any idea what is wrong?

  • This seems to address what you are trying to achieve nefaria.com/2016/04/… – Sum1sAdmin May 2 '18 at 11:04
  • @Sum1sAdmin Thanks, the article describes Virtualbox running on Ubuntu launching a Windows VM. My case is the opposite. – Mickael Marrache May 2 '18 at 11:07
  • Can a client version of Windows even do VLAN trunking? I've never heard of this. – Michael Hampton May 2 '18 at 16:31
  • @Michael Hampton Normally it's up to the NIC driver - not a native Windows thing. – Mintra May 3 '18 at 8:49
0

I would expect that when you created the VLANs in Realtek diagnostics it created additional virtual network adapters on your PC, one for each VLAN. You would need to bridge these individually into VirtualBox as separate networks and present them to the VM as separate virtual NICs to be configured inside Ubuntu in the conventional way - no need for Ubuntu to be aware of the VLANs as the tags have been processed and removed by the Realtek tool by then.

  • Yes I tried to do that... but virtualbox doesn't show me the virtual adapters so that I can select them. I can see them in the network interfaces on windows though. – Mickael Marrache May 2 '18 at 18:11
  • Possibly you need to go into their properties in the Windows network interfaces view and enable the VirtualBox NDIS6 networking driver - this may not be on by default for Realtek-created adapters made after your VirtualBox installation. – Mintra May 3 '18 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.