0

I installed awstats and it looks in principle ok.

The only thing is, that I still have only one visitor with all the hits and only an "unknown ip" as addresses.

All other thinks (OS, browser etc.) look ok

Any Idea where to search?

1

I was lazy with my apache2 configuration.

I put all vmhost log data into /var/log/apache2/other_vhosts_access.log

It is ok for me.

But then apache2 has a different log format.

A look at apache2.conf tells - look at vhost_combined and the %v:%p at the start :

LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

And this does not fit to awstats

LogFormat=1 #that is:
#LogFormat = "%host %other %logname %time1 %methodurl %code %bytesd %refererquot %uaquot"

Solutions:

  1. Make your log files less lazy and put them in a separate file in apache2 config (recommended)

or

  1. Change the logfile format in apache2 to: LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined ie. remove the "%v:%p"

or

  1. Change the logfile parameter in your awstats to: LogFormat = "%other %host %other %logname %time1 %methodurl %code %bytesd %refererquot %uaquot" ie. add an %other at the beginning of the line, to get rid of domain:port

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.