I want to share a folder with samba. I want the folder to be read only and I don't want the user to have to enter a username or password.

I add the configuration to my smb.conf file and the folder is exposed as a share. The problem is I cannot access any folders below that directory.

What is the easiest way to allow the user to see the shared folders and the files below the folder?

  • 2
    You should begin with copying your smb.conf here – nrgyz Dec 4 '09 at 15:43

You should set the filespermission for the diretory to 774.
chmod -R 774 your_directory

Then set the guest user in the [global] section and enable the share in smb.conf.
security = share
guest account = nobody

Now create the share
comment = your share access
path = /path_to_share
browseable = yes
read only = yes
guest ok = yes

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.