0

I am attempting to mount an FTPS connection but am not having much success in getting it to automatically mount. I am using AWS Linux. I can get it working from the command line with:

curlftpfs <ipaddress>:/incoming /home/<username>/autohcidev/ -o ssl,no_verify_peer,allow_other,debug

The credentials are specified in /root/.netrc. That connection seems to work fine:

FUSE library version: 2.9.4
nullpath_ok: 0
nopath: 0
utime_omit_ok: 0
unique: 1, opcode: INIT (26), nodeid: 0, insize: 56, pid: 0
INIT: 7.26
flags=0x001ffffb
max_readahead=0x00020000
   INIT: 7.19
   flags=0x00000011
   max_readahead=0x00020000
   max_write=0x00020000
   max_background=0
   congestion_threshold=0
   unique: 1, success, outsize: 40

so with some confidence I add this into /etc/fstab :

curlftpfs#<ipaddress>:/incoming /home/<username>/autohcidev/ fuse ssl,no_verify_peer,allow_other,uid=512,gid=512,umask=0002 0 0

and then I enter

mount -a

and I get:

mount: wrong fs type, bad option, bad superblock on curlftpfs#<ipaddress>:/incoming,
   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.

dmesg | tail gives the following:

[    2.281634] input: ImExPS/2 Generic Explorer Mouse as /devices/platform/i8042/serio1/input/input4
[    2.343044] ACPI: Power Button [PWRF]
[    2.345804] input: Sleep Button as /devices/LNXSYSTM:00/LNXSLPBN:00/input/input5
[    2.411051] ACPI: Sleep Button [SLPF]
[    2.491384] mousedev: PS/2 mouse device common for all mice
[    3.525191] EXT4-fs (xvda1): re-mounted. Opts: (null)
[    3.550044] fuse init (API version 7.26)
[    3.796345] NET: Registered protocol family 10
[    3.803184] Segment Routing with IPv6
[    6.212849] random: crng init done

The same thing before and after mount -a

That userid and group ID are valid on the local server. I also tried a user ID and group ID that are valid on the remote server. Some googling suggested that I need to install some sort of helper program. I installed cifs-utils as was suggestged at one point, but that felt like a long shot and indeed it did not seem to help.

sudo yum install nfs-common

returns the following on AWS Linux:

Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main                                                | 2.1 kB     00:00
amzn-updates                                             | 2.5 kB     00:00
No package nfs-common available.
Error: Nothing to do

So at this point I'm thinking that I need to find something equivalent for AWS linux, but I seem to only be able to find documentation about EFS. Any insight would be appreciated.

  • So what did you see when you ran dmesg | tail after the mount failed? – Michael Hampton May 4 '18 at 19:37
  • I have added those details above – Bernard Lechler May 4 '18 at 19:46
  • Hm, I see nothing useful there. – Michael Hampton May 4 '18 at 19:47
  • For anybody coming through here looking for a solution, I ended up switching over to a cron that checks the folder and transfers the files. I would have liked to use curlftpfs, but maybe there is just something about AWS Linux? – Bernard Lechler May 10 '18 at 20:32
0

The fstab prefix notation that you are using is deprecated. In the fstab man page:

              mount(8) and umount(8) support filesystem subtypes.  The subtype
              is defined by '.subtype' suffix.  For example 'fuse.sshfs'. It's
              recommended  to  use subtype notation rather than add any prefix
              to the first fstab field  (for  example  'sshfs#example.com'  is
              deprecated).

This means that instead of:

curlftpfs#<ipaddress>:/incoming /home/<username>/autohcidev/ fuse ssl,no_verify_peer,allow_other,uid=512,gid=512,umask=0002 0 0

You should use:

<ipaddress>:/incoming /home/<username>/autohcidev/ fuse.curlftpfs ssl,no_verify_peer,allow_other,uid=512,gid=512,umask=0002 0 0
  • mount: wrong fs type, bad option, bad superblock on <ipaddress>/incoming/, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so. – Bernard Lechler May 4 '18 at 19:58
  • Hmm. It could be that curlftpfs just doesn't support being in fstab at all. That seems strange though. – Michael Hampton May 4 '18 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.