My customer has a SBS 2008 Server and uses the built-in Exchange Server 2007. I migrated their mailboxes to Office 365 via a cutover migration. Now comes the impossible part. Their workstations are a mix of WIndows 7 and WIndows 10. Outlook on those workstations is a mix of 2010 and 2013.

I can manually configure their Outlook to point to Office 365 but it will only stay for maybe 4 hours and reverts back to their Exchange Server. Simply opening Outlook and letting it sit it reverts back. I can tell when the Outlook 2010 workstations revert back because a pop-up asking for their email address and password keeps popping up. I can tell when the Outlook 2013 workstations revert back because they get a pop-up stating "the microsoft exchange server administrator has made a change that requires you to quit and restart outlook". At that point Outlook has reverted back to pointing to their Exchange Server.

I have tried stopping all the Microsoft Exchange services on their Exchange Server. Nothing I have tried works. I cannot keep Outlook pointed to Office 365. It keeps automatically reverting back. My guess is that I need to change the autodiscover services on the Exchange Server but that is just a guess. Does anyone know how to do this?

  • Based on my own experience, the login/password prompt can also popup when the connection to the AD controller is lost, or sometimes just randomly without any reason. – danzel May 5 '18 at 18:27

You need to either remove the Exchange SCP from AD or disable Outlook's SCP lookup with Group Policy.

  • I can confirm this is the correct answer. In some cases I have gone so far as to both remove Exchange SCP from AD in ADSI Edit and disabling Outlook’s SCP lookup with Group Policy. Also make sure you change your auto discover record in DNS. – user5870571 May 5 '18 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.