0

Our application is being hosted on GoDaddy (plesk). We need to enable 'php_soap' extension for our application to work. We contacted the customer support that we don't have access to php.ini file to do so but they told us that we can use .user.ini instead. We've tried doing that but .user.ini doesn't seem to enable php_soap extension when we added the line.

extension=php_soap.dll

after testing if .user.ini works at all by changing another setting upload_max_filesize and it works. But enabling the soap extension doesn't work

  • You may be prohibited to load extensions in fact. – Patrick Mevzek May 7 '18 at 13:28
0

Welcome to serverfault cominitutiy .!

Try to create a php.ini file and add below line :

extension=php_soap.dll

in some case it's commented so try to uncomment .

Also you can check the server extensions with creating a info.php file , So you should create a file name

info.php

However you had to add this line to info.php file as well :

<?php

// Show all information, defaults to INFO_ALL
phpinfo();

// Show just the module information.
// phpinfo(8) yields identical results.
phpinfo(INFO_MODULES);

?>

Finally you should restart web server to load extension modules

Alternative contact your provider to help you out .

Have great day future friend . ;-)

  • I have no access to php.ini – 7asobate- May 7 '18 at 12:35
  • I can only access .user.ini file which supposedly overrides php.ini but I can't get it to enable the extension – 7asobate- May 7 '18 at 12:37
  • try to create one php.ini file so far , also did you tried to create info.php i have provided above ? – Nathanael May 7 '18 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.