1

Installing teamviewer-host.x86_64.rpm on CentOS Linux release 7.5.1804 yum produced the following errors:

--> Finished Dependency Resolution
Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
Requires: qt5-qtbase(x86-64) = 5.6.2
Installing: qt5-qtbase-5.9.2-3.el7.x86_64 (base)
qt5-qtbase(x86-64) = 5.9.2-3.el7
Error: Package: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
Requires: qt5-qtdeclarative(x86-64) = 5.6.2
Installing: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (base)
qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

 I fixed it by:

wget http://dl.fedoraproject.org/pub/epel/testing/7/x86_64/Packages/q/qt5-qtwebkit-5.9.1-1.el7.x86_64.rpm
 yum install qt5-qtwebkit-5.9.1-1.el7.x86_64.rpm
yum install teamviewer-host.x86_64.rpm

Then everything worked fine.

 

1

Just posting this answer because I debugged and searched all day so maybe someone else won't have to. It is probably a temporary repo issue while epel upgrades qt5.2 to qt5.9

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.