2

Background

I have an Ubuntu 16.04 clean VM, and I am trying to install the latest version of graylog on it. Unfortunately, it is failing.

What did I do?

First I created a clean VM with the afore mentioned OS. Then I followed the official instructions step by step:

http://docs.graylog.org/en/2.4/pages/installation/os/ubuntu.html

I installed the prerequisites, mongo DB, ElasticSearch and last but not least, Graylog 2.4.

I also configured /etc/elasticsearch/elasticsearch.yml to have cluster.name: graylog ( before installing graylog ).

Graylog conifg

Now, we both know graylog won't start out of the box. You need to do some config. My configuration for /etc/graylog/server/server.conf is really simple:

rest_listen_uri = http://0.0.0.0:9000/api/
web_listen_uri = http://0.0.0.0:9000/

That's it. I also created the necessary keys and passwords as usual.

What's the problem

When I connect to my server via its public IP with port 9000, I get the following error message:

We are experiencing problems connecting to the Graylog server running on http://10.0.0.11:9000/api/. Please verify that the server is healthy and working correctly.

You will be automatically redirected to the previous page once we can connect to the server.

Do you need a hand? We can help you.

Following are the details:

Error message Request has been terminated Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc. Original Request GET http://10.0.0.11:9000/api/system/sessions Status code undefined Full error message Error: Request has been terminated Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.

I can access the web page, but I immediately see the given error. I have another instance configured the same way but with graylog 2.2 and it never gave me any trouble.

What did you try to solve the problem?

My first idea was to check the health of the services. When I run sudo systemctl status XXXX, replacing XXXX with mongod, elasticsearch and graylog-server they all are active and running.

I also checked for similar errors in this forum but they are for different OSs so I am kinda lost here.

GIve me some specs!

Following are the specs of my OS (lsb_release -a):

No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 16.04.4 LTS Release: 16.04 Codename: xenial

And the browser I am using:

Firefox Quantum 60.0 ( 64-bit )

Questions

  1. Did I miss come config step?
  2. Why am I getting this error and how can I fix it?
  • What did you set web_endpoint_uri to? – Michael Hampton May 15 '18 at 13:29
  • I don't have web_endpoint_uri set. According to the docs, it will use rest_transport_uri which is set to the Public IP of the server. – Flame_Phoenix May 16 '18 at 13:11
0

Answer

This was a configuration issue. I fixed it by using the following config:

rest_listen_uri = http://0.0.0.0:9000/api/
web_listen_uri = http://0.0.0.0:9000/
#web_endpoint_uri =
rest_transport_uri = http://<AZURE_PUBLIC_IP>:9000/api/

Do note that web_endpoint_uri is commented. I still don't quite get how all the pieces work, but this seems to have done the trick.

As a bonus round, this is equivalent to the following:

rest_listen_uri = http://0.0.0.0:9000/api/
web_listen_uri = http://0.0.0.0:9000/
web_endpoint_uri = http://<AZURE_PUBLIC_IP>:9000/api/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.