Something very odd is happening. We have a Windows Server 2003 computer that is NOT part of our domain. It is simply just serving up files via file shares (don't ask me why they used Win 2k3 for a simple fileserver).

Anyways I'm attempting to join it to our domain and it's giving me the dreaded

A Domain Controller for the domain <domain> could not be contacted

Clicking details it's giving me:

The error was: "DNS name does not exist."  
(error code 0x0000232B RCODE_NAME_ERROR)

Which is very odd because I can use nslookup to successfully query the NS for the DC's FQDN and it comes back with the right IP.

Additionally, using:

nslookup -q=srv _ldap._tcp.dc._msdcs.<domain>

Brings back the correct info:

Server:  <dc name>.<domain>

_ldap._tcp.dc._msdcs.<domain>   SRV service location:
  priority       = 0
  weight         = 100
  port           = 389
  svr hostname   = <dc name>.<domain>
<dc name>.<domain>  internet address =

I can ping the DC from the fileserver and I can ping the fileserver from the DC.

What the heck is going on?! Why can't my fileserver join our domain?

We only have 1 DC set up on our small network (less than 20 users). Surely, I'm missing something?

EDIT: Oh, yeah, the DC is also the DNS server and on the fileserver it's primary DNS server is the DC. EDIT2: The DC is a Win Server 2k3 box

  • Is your domain controller SBS? – Daniel Lucas Dec 5 '09 at 3:56
  • No the DC is Win Server 2k3 RC2 – smoak Dec 7 '09 at 18:30
up vote 4 down vote accepted

Just for the heck of it, when you're trying to join the domain are you typing in the NetBIOS name of the domain or the DNS name of the domain? Whichever one you're trying, try the other instead.

  • 1
    and check that your clock/date is synchronized against the DC – pauska Dec 5 '09 at 14:27
  • @pauska: The dates seem to be synchronized (at least down to the minute). Does it have to be synchronized down to the second? – smoak Dec 7 '09 at 18:32
  • That was it! For some strange reason the NetBIOS name worked instead of the actual DNS name. For all other computers in the office, it's worked by using the DNS name. Strange...but it works! – smoak Dec 8 '09 at 1:03
  • Glad you got it sorted out. Now you just need to make sure that DNS is operating correctly in your environment as I'd be a little concerned about it based on the problem you had trying to join the domain using the DNS name. – joeqwerty Dec 8 '09 at 1:18

It all sounds reasonable, but obviously some little thing isn't quick "clicking".

This is one of the times when I'd throw the Microsoft "Network Monitor" optional component onto the file server computer and sniff the traffic during the domain join operation to see what might be going awry.

Take 5 minutes, throw Netmon onto the box, and see what you can see.

What DNS Server is your DHCP server handing out?

Is your DHCP server handing out a search domain?

If you only have one DNS server you might be handing out a public DNS server, this can confuse the server you are trying to join because it does not know what your "domain name" is and is looking for it on a public server because the search domain is missing..


  • I have manually set the DNS server on the fileserver to be that of the DC. – smoak Dec 7 '09 at 18:13
  • Is it the only DNS? or is there a secondary? – Thomas Denton Dec 7 '09 at 23:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.