1

I have Windows server 2016 1607 that is not part of domain. In Local group policy editor > Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Windows Update I have enabled following settings:

  • Always automatically restart at scheduled time
    • Restart timer: 15 minutes
  • Configure automatic updates
    • 4 Auto download and schedule the install
    • 0 every day
    • Scheduled install time 03:00

But when I go to Settings > Update & security > Windows update I see this text: Your device is scheduled to restart at ‏‎12.30 by your organization..

If I run sconfig I see this: 5) Windows update settings: Automatic.

Where does the time 12:30 come from and how I can make sure server reboots right after installing updates during night instead of middle of the day?

EDIT: 12:30 went by and server did not reboot. Yet it still says that restart is scheduled for 12:30.

EDIT2: Update settings from registry:

    Hive: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate

Name                           Property
----                           --------
AU                             NoAutoUpdate                           : 0
                               AUOptions                              : 4
                               ScheduledInstallDay                    : 0
                               ScheduledInstallTime                   : 3
                               AlwaysAutoRebootAtScheduledTime        : 1
                               AlwaysAutoRebootAtScheduledTimeMinutes : 15
                               NoAutoRebootWithLoggedOnUsers          : 0

EDIT3: The supposed reboot time passed again and nothing happened. After that I decided to reboot manually. I guess I will have to wait untill next updates to see the problem persists.

  • Please share the values of the registry path: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate, and all its subkeys (if present). – Am_I_Helpful May 17 '18 at 20:12
  • @Am_I_Helpful They are now included in my original post. – Madoc Comadrin May 18 '18 at 5:30
0

With these settings June updates got intalled at desired time and server rebooted automatically during maintenance Window.

It maybe that the Windows update settings were not fully applied before I rebooted the server manually. Or the might have been some issues with May updates that prevented reboot happening automatically.

  • It seems you changed the settings through gpedit.msc, and didn't reboot the server. This looks to be the reason why the settings didn't take effect in the first place. At the first place, my guess is the server didn't reboot not because of any problem in the patch, but, rather the settings made but the server was not rebooted for long. Anyway, good to know that the problem has been resolved. – Am_I_Helpful Jun 18 '18 at 17:03
  • That might be it, though I find it odd that the Windows update claimed there was scheduled reboot but that never actually happened. – Madoc Comadrin Jun 18 '18 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.