I'm trying to get a 2 Node Hyper-converged Fail-over cluster setup with 2016 Server and Storage Spaces Direct.

I am able to Validate (with no errors) and Create the Cluster with the S2D tests included but when I run Enable-S2D on the Cluster the cluster fails.

What I can see happening is that during the S2D setup the Cluster Service begins to restart repeatedly.

On both nodes I get errors

The Service Control Manager tried to take a corrective action (Restart the service) after the unexpected termination of the Cluster Service service, but this action failed with the following error:
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

The Cluster Service service terminated unexpectedly. It has done this "x" time(s). The following corrective action will be taken in 15000 milliseconds: Restart the service.

The Cluster Service service terminated with the following service-specific error:
The cluster join operation was aborted.

As well as Application Event 1000

Faulting application name: clussvc.exe, version: 10.0.14393.2273, time stamp: 0x5ae40d1f
Faulting module name: clussvc.exe, version: 10.0.14393.2273, time stamp: 0x5ae40d1f
Exception code: 0xc0000409
Fault offset: 0x00000000000332f1
Faulting process id: 0x16d0
Faulting application start time: 0x01d3ef1c502ea68c
Faulting application path: C:\WINDOWS\Cluster\clussvc.exe
Faulting module path: C:\WINDOWS\Cluster\clussvc.exe
Report Id: a1700bc1-bf18-464e-b35c-b759832e1382
Faulting package full name:
Faulting package-relative application ID:

I've Destroyed and recreated the cluster several times but no luck.

My drives are all clean and have "CanPool = True". I have a file-share witness configured and validated.

  • 1
    You might want to remove your drives from S2D pool, wipe them off to get rid of metadata and add back.
    – NISMO1968
    May 19, 2018 at 14:04

3 Answers 3


Don’t do S2D with only two nodes as it’s nothing but begging for troubles! Failover isn’t reliable and you can’t lose second node (obviously!) or second disk/ssd in a row. In RL it means your cluster will collapse with a very high probability during patch process and you’ll have hard times getting your data back... In your particular case you have to re-create S2D pool, create virtual disk and only after you have working shared storage you start playing with f/o cluster thing.

  • 2
    This is true! Anything below 4 nodes is barely usable with S2D.
    – NISMO1968
    May 19, 2018 at 14:05
  • Is it possible to enable S2D before creating a Cluster? I thought the cluster had to be created first for S2D to create the pool. May 21, 2018 at 21:13

Plus one for not to use S2D with two nodes. Starting from poor reliability and ending with short features list in such scenario. There are a lot of topics with comparing S2D with any other solutions, but this one is my favorite. https://community.spiceworks.com/topic/1445491-s2d-vs-starwind-virtual-san For two nodes you can take a look at something like HP Storevirtual (but AFAIR right now it's on EOL stage) https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=VSA1TB-S or Starwind which is basically free with its features. https://www.starwindsoftware.com/starwind-virtual-san

  • Unfortunately my storage is larger than is allowed for the free version for either product. May 21, 2018 at 21:15
  • 1
    There’s no capacity limitation within free version of StarWind. May 22, 2018 at 4:26
  • Is there a specific version or Edition that's free? I see the Standard that handles up to 4TB and then the Enterprise and Data-center that are unlimited. May 22, 2018 at 5:30
  • 1
    I guess StarWind Virtual SAN Free is what you're looking for. starwindsoftware.com/starwind-virtual-san-free May 22, 2018 at 9:08

Have an update,

After looking around found another post that Failover-Clustering/S2D nodes can not have Domain Controllers installed on them.

Storage spaces direct Enable-ClusterStorageSpacesDirect returns with error Failed to start health providers

I could not find any other supporting information on this claim. (If anyone can find a reference as to why I would appreciate it.)

However, after cleaning the disks and re-initializing the storage and receiving the same errors I removed the ADDS from the Nodes and was then able to successfully configure S2D and Fail-over Clustering.

I think at one point I had actually believed that this was the case, that a DC could not be on a host node.

Sounds like few people like S2D with only 2 nodes so I will look in to a replacement option for the future.

I appreciate your help and recomendations.

  • 1
    Thanks for your update! I totally missed DC part. Never mix DC with anything else, and always go virtualized. May 22, 2018 at 9:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .