0

Based on this link how to set up SPF and answer in closed topic here My dns record looks like this

 v=spf1 a mx ip4:xxx.xxx.xx.xx -all include:_spf.google.com ~all

but google throws an error

spf=softfail (google.com: domain of transitioning admin@smmmoney.com does not designate xx.xx.xxx.xxx as permitted sender) smtp.mailfrom=admin@smmmoney.com;

Is my record valid? Why doesn't it pass Gmail's filter? I am using PLESK 17.8.11 on VPS server.

EDIT 2

My domain is smmmoney.com. Changed as advised but still not working. Dns shows record is up to date.

  • Tell us the domain name(s) and addresses in question. We can't give proper help without a clear problem statement. – MadHatter May 20 '18 at 8:56
  • 1
    Whatever is your problem now, it's different and an error message is probably different. If so, please close this question and ask again with a new error message. This way the site will be readable for others in future. – kubanczyk May 20 '18 at 17:16
  • "Changed as advised but still not working." Gmail likely caches it for a bit. Wait 24 hours and retry. – ceejayoz May 20 '18 at 17:20
3

You have a -all in the middle of the record.
all practically only makes sense at the end of the record.
Most likely everything after the -all is ignored by receiving servers.

1

You have -all and ~all in your record. Try with:

v=spf1 a mx ip4:xxx.xxx.xx.xx include:_spf.google.com -all

Also did you verify that all of your DNS servers for example.com are correctly updated?

host -t ns example.com
host -t txt example.com name-of-dns1
host -t txt example.com name-of-dns2

and so on...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.