0

My phabricator server is dying from time to time with the following log:

[Tue May 22 14:58:55.336308 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: [2018-05-22 11:58:55] EXCEPTION: (PhutilTypeCheckException) Parameter 'char' has invalid type. Expected type 'optional int', got type 'string'. at [<phutil>/src/parser/PhutilTypeSpec.php:59]
[Tue May 22 14:58:55.336341 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: arcanist(head=8794ce1eaca0b3ef020e2cd5d2d5479fd3626b9f), phabricator(head=8ada2bc4fe74423674bce4df0b7f3a144a2c771d), phutil(head=f3e10579f640ebad648c56f677164647ab7251a4, ref.master=69161db9ed33)
[Tue May 22 14:58:55.336344 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #0 <#2> PhutilTypeSpec::check(string, string) called at [<phutil>/src/parser/PhutilTypeSpec.php:169]
[Tue May 22 14:58:55.336347 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #1 <#2> PhutilTypeSpec::checkMap(array, array) called at [<phabricator>/src/applications/harbormaster/storage/build/HarbormasterBuildLintMessage.php:81]
[Tue May 22 14:58:55.336349 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #2 <#2> HarbormasterBuildLintMessage::newFromDictionary(HarbormasterBuildTarget, array) called at [<phabricator>/src/applications/harbormaster/conduit/HarbormasterSendMessageConduitAPIMethod.php:237]
[Tue May 22 14:58:55.336362 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #3 <#2> HarbormasterSendMessageConduitAPIMethod::execute(ConduitAPIRequest) called at [<phabricator>/src/applications/conduit/method/ConduitAPIMethod.php:123]
[Tue May 22 14:58:55.336365 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #4 <#2> ConduitAPIMethod::executeMethod(ConduitAPIRequest) called at [<phabricator>/src/applications/conduit/call/ConduitCall.php:131]
[Tue May 22 14:58:55.336367 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #5 <#2> ConduitCall::executeMethod() called at [<phabricator>/src/applications/conduit/call/ConduitCall.php:81]
[Tue May 22 14:58:55.336369 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #6 <#2> ConduitCall::execute() called at [<phabricator>/src/applications/conduit/controller/PhabricatorConduitAPIController.php:83]
[Tue May 22 14:58:55.336371 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #7 phlog(PhutilTypeCheckException) called at [<phabricator>/src/applications/conduit/controller/PhabricatorConduitAPIController.php:103]
[Tue May 22 14:58:55.336373 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #8 PhabricatorConduitAPIController::handleRequest(AphrontRequest) called at [<phabricator>/src/aphront/configuration/AphrontApplicationConfiguration.php:258]
[Tue May 22 14:58:55.336375 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #9 AphrontApplicationConfiguration::processRequest(AphrontRequest, PhutilDeferredLog, AphrontPHPHTTPSink, MultimeterControl) called at [<phabricator>/src/aphront/configuration/AphrontApplicationConfiguration.php:181]
[Tue May 22 14:58:55.336378 2018] [:error] [pid 4531]  FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message:   #10 AphrontApplicationConfiguration::runHTTPRequest(AphrontPHPHTTPSink) called at [<phabricator>/webroot/index.php:17]

After a restart it starts working again, but this is very annoying. I would appreciate if someone knew how to solve it.

  • Update it, and if that fails, file a bug report. – Michael Hampton May 22 '18 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.