0

I would like to setup a limited-size RAID 10 array for the OS with write-through enabled for safety (no battery/UPS), and use the rest of the disks in a RAID 0 with write-back enabled for performance (data is replacable). This is with a LSI MegaRAID SAS 9260-4i using the latest firmware 12.15.0-0239

Setting up the RAID 10 works OK like:

megacli -CfgSpanAdd -r10 -Array0[252:0,252:1] -Array1[252:2,252:3] WT RA Direct NoCachedBadBBU -sz500GB -a0 Adapter 0: Created VD 0
Adapter 0: Configured the Adapter!!
Exit Code: 0x00

But then I can't seem to get the RAID 0 added with the rest of the space. i.e.

megacli -CfgLdAdd -r0 [252:0,252:1,252:2,252:3] WB RA Direct CachedBadBBU -a0
Drives are not consistent with configured Array.
Exit Code: 0x03

Or trying to add it as another span instead

megacli -CfgSpanAdd -r0 -Array0[252:0,252:1,252:2,252:3] WT RA Direct NoCachedBadBBU -a0
Invalid input at or near token WT
Exit Code: 0x01

megacli -CfgSpanAdd -r0 [252:0,252:1,252:2,252:3] WT RA Direct NoCachedBadBBU -a0
Invalid input at or near token [252:0,252:1,252:2,252:3
Exit Code: 0x01

Or just guessing

megacli -CfgAllFreeDrv -r0 WB RA Direct CachedBadBBU -a0
No Configurable Disk Available for Configuraiton on Adapter 0.

Is it just not possible to have multiple raid groups on the same disks with MegaRAID? or do I need to somehow create the two virtual disks before configuring them? Probably would be easier with a GUI but trying to do this all remotely via megacli.

  • Just went with raid 5 as a comrpomise – Jeremy May 29 '18 at 21:55
0

Most hardware RAID controllers can only use complete disks for volumes (I am not aware of any model that can use only part of a disk for this).

Use software RAID if you need this or add a pair of disks for the system volume.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.