0

My WAN router, a TP-LINK Archer C2 doesn't have a local DNS server for DHCP'd clients so I was looking for another solution. I found the Dual DHCP DNS Server for Windows and installed it on the LAN server. It seems to work fine when I'm inspecting the network traffic.

When a client wants an IP address, it gets a DHCP response with an IP address, DNS and gateway addresses. The server's address is 192.168.18.2 and the TP-LINK router has 192.168.18.1. The router option (3) is correctly set to 192.168.18.1.

But neither a Samsung Android phone nor the Kyocera printer regard the default dateway value. They happily accept their own IP address but state they have no gateway and cannot connect to the internet.

Both a simple tool named dhcptest.exe and Wireshark parse the DHCP response and list the router IP address as expected.

What's going on here? Why does every client ignore the gateway address from the one server when they accept the gateway address from the TP-LINK DHCP server? It's driving me mad and wanting to throw the TP-LINK device out of the window and get a decent router that can handle LAN hostnames properly.

  • Please provide a printscreen of the tplink settings you set, just to be sure, as if ok I would try maybe to flash it – yagmoth555 May 28 '18 at 9:45
  • It turned out that I missed opening the DNS port UDP 53 on the Windows machine, after I had already opened DHCP UDP 67. Now everything works as expected. Except the Kyocera printer, it still hasn't received the gateway. Maybe it'll catch up later. – ygoe May 28 '18 at 13:19
0

DHCP options do not refresh instantaneously. Instead, the client re-requests the lease after half its lifetime. If you need to refresh the options before that refresh manually, disconnect and reconnect, or reboot the client.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.