1

I have a Windows 2016 solution on which users access a Remote Desktop published by remote desktop services. Its the new version of RDP that comes in via HTTPS through the RD Web gateway and is loadbalanced between a pair of session host servers.

On the client's machines, they have the connection set up in RemoteApp and Desktop Connections.

Everything was working fine until wednesday last week whereupon users found they were no longer able to connect to their desktops... but its not affecting everybody. If I try and connect in this way from my laptop, I get in straight away, If I try it from my desktop in the office, I cannot get in.

The error message given just says "This computer can't connect to the remote computer". No further details.

I've scoured the logs on the server side and I cant see anything to see why it might suddenly not be accepting connections for some people.

I'm able to workaround the issue by setting up normal RDP connections directly to the session host servers, but this negates the load-balancing thats in place and isn't the way forward.

I've made sure that all the latest updates are in place, both on the servers and on the client machines.

I'd prefer the above to be a more detailed explanation of the issue, but I cant really say much else. Nothing I have tried so far has made a difference. I tried lowering the RDP security levels, I tried disabling the NPS, I tried rebooting everything across the board (it is Windows, afterall!).

Any suggestions or advice is welcome!

  • 1
    Ist TCP port 3389 reacheable? – marsh-wiggle May 29 '18 at 9:08
  • It absolutely is... but the connections that are struggling are coming in to the RD Gateway in 443. – John May 29 '18 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.