0

A colleague of mine unfortunately removed a package with zypper ending up removing zypper from the server.

I am trying to reinstall it via the .rpm package.

I have tried downloading it via wget:

wget http://download.opensuse.org/distribution/11.4/repo/oss/suse/i586/zypper-1.5.3.i586.rpm
asking libproxy about url 'http://download.opensuse.org/distribution/11.4/repo/oss/suse/i586/zypper-1.5.3.i586.rpm'
libproxy suggest to use 'direct://'
--2018-05-31 10:57:11--  http://download.opensuse.org/distribution/11.4/repo/oss/suse/i586/zypper-1.5.3.i586.rpm
Resolving download.opensuse.org... 195.135.221.134, 2620:113:80c0:8::13
Connecting to download.opensuse.org|195.135.221.134|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://ftp5.gwdg.de/pub/opensuse/discontinued/distribution/11.4/repo/oss/suse/i586/zypper-1.5.3.i586.rpm [following]
asking libproxy about url 'http://ftp5.gwdg.de/pub/opensuse/discontinued/distribution/11.4/repo/oss/suse/i586/zypper-1.5.3.i586.rpm'
libproxy suggest to use 'direct://'
--2018-05-31 10:57:11--  http://ftp5.gwdg.de/pub/opensuse/discontinued/distribution/11.4/repo/oss/suse/i586/zypper-1.5.3.i586.rpm
Resolving ftp5.gwdg.de... 134.76.12.6, 2001:638:60f:110::1:2
Connecting to ftp5.gwdg.de|134.76.12.6|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2018-05-31 10:57:11 ERROR 404: Not Found.

Since the package is old I only found these urls:

http://rpm.pbone.net/index.php3/stat/4/idpl/15618018/dir/opensuse_11.x/com/zypper-1.5.3-3.2.i586.rpm.html

http://www.rpmseek.com/rpm-dl/zypper-1.5.3-3.2.i586.html?hl=com&cx=0:-:0:8612831:0:0:0

I am not able to download the linked files, how can I download them? Is there any other place where I can find it?

UPDATE


I was able to find the package here:

https://ftp5.gwdg.de/pub/opensuse/discontinued/distribution/11.4/repo/oss/suse/i586/

However it seems I am still missing some dependencies:

sudo rpm -i zypper-1.5.3-3.2.i586.rpm 
error: Failed dependencies:
    libzypp >= 8.12.1 is needed by zypper-1.5.3-3.2.i586
    libaugeas.so.0 is needed by zypper-1.5.3-3.2.i586
    libaugeas.so.0(AUGEAS_0.1.0) is needed by zypper-1.5.3-3.2.i586
    libaugeas.so.0(AUGEAS_0.8.0) is needed by zypper-1.5.3-3.2.i586
    libgcc_s.so.1 is needed by zypper-1.5.3-3.2.i586
    libgcc_s.so.1(GCC_3.0) is needed by zypper-1.5.3-3.2.i586
    libreadline.so.6 is needed by zypper-1.5.3-3.2.i586
    libstdc++.so.6 is needed by zypper-1.5.3-3.2.i586
    libstdc++.so.6(CXXABI_1.3) is needed by zypper-1.5.3-3.2.i586
    libstdc++.so.6(CXXABI_1.3.1) is needed by zypper-1.5.3-3.2.i586
    libstdc++.so.6(GLIBCXX_3.4) is needed by zypper-1.5.3-3.2.i586
    libstdc++.so.6(GLIBCXX_3.4.10) is needed by zypper-1.5.3-3.2.i586
    libstdc++.so.6(GLIBCXX_3.4.11) is needed by zypper-1.5.3-3.2.i586
    libstdc++.so.6(GLIBCXX_3.4.14) is needed by zypper-1.5.3-3.2.i586
    libstdc++.so.6(GLIBCXX_3.4.9) is needed by zypper-1.5.3-3.2.i586
    libzypp.so.810 is needed by zypper-1.5.3-3.2.i586

I am trying to download and install all the missing dipendencies from that url, however I got stuck here:

sudo rpm -i gpg2-2.0.16-7.1.i586.rpm 
error: Failed dependencies:
    dirmngr is needed by gpg2-2.0.16-7.1.i586
    libadns.so.1 is needed by gpg2-2.0.16-7.1.i586
    libassuan.so.0 is needed by gpg2-2.0.16-7.1.i586
    libassuan.so.0(LIBASSUAN_1.0) is needed by gpg2-2.0.16-7.1.i586
    libbz2.so.1 is needed by gpg2-2.0.16-7.1.i586
    libcurl.so.4 is needed by gpg2-2.0.16-7.1.i586
    libgcrypt.so.11 is needed by gpg2-2.0.16-7.1.i586
    libgcrypt.so.11(GCRYPT_1.2) is needed by gpg2-2.0.16-7.1.i586
    libgpg-error.so.0 is needed by gpg2-2.0.16-7.1.i586
    libksba.so.8 is needed by gpg2-2.0.16-7.1.i586
    libksba.so.8(KSBA_0.9) is needed by gpg2-2.0.16-7.1.i586
    libpth.so.20 is needed by gpg2-2.0.16-7.1.i586
    libreadline.so.6 is needed by gpg2-2.0.16-7.1.i586
    libusb-0.1.so.4 is needed by gpg2-2.0.16-7.1.i586
srvM:/srv/www/htdocs # sudo rpm -i dirmngr-1.1.0-4.1.i586.rpm 
error: Failed dependencies:
    openssl is needed by dirmngr-1.1.0-4.1.i586
    libassuan.so.0 is needed by dirmngr-1.1.0-4.1.i586
    libassuan.so.0(LIBASSUAN_1.0) is needed by dirmngr-1.1.0-4.1.i586
    libgcrypt.so.11 is needed by dirmngr-1.1.0-4.1.i586
    libgcrypt.so.11(GCRYPT_1.2) is needed by dirmngr-1.1.0-4.1.i586
    libgpg-error.so.0 is needed by dirmngr-1.1.0-4.1.i586
    libksba.so.8 is needed by dirmngr-1.1.0-4.1.i586
    libksba.so.8(KSBA_0.9) is needed by dirmngr-1.1.0-4.1.i586
    libpth.so.20 is needed by dirmngr-1.1.0-4.1.i586
srvM:/srv/www/htdocs # sudo rpm -i openssl-1.0.0c-17.1.i586.rpm 
srvM:/srv/www/htdocs # sudo rpm -i dirmngr-1.1.0-4.1.i586.rpm 
error: Failed dependencies:
    libassuan.so.0 is needed by dirmngr-1.1.0-4.1.i586
    libassuan.so.0(LIBASSUAN_1.0) is needed by dirmngr-1.1.0-4.1.i586
    libgcrypt.so.11 is needed by dirmngr-1.1.0-4.1.i586
    libgcrypt.so.11(GCRYPT_1.2) is needed by dirmngr-1.1.0-4.1.i586
    libgpg-error.so.0 is needed by dirmngr-1.1.0-4.1.i586
    libksba.so.8 is needed by dirmngr-1.1.0-4.1.i586
    libksba.so.8(KSBA_0.9) is needed by dirmngr-1.1.0-4.1.i586
    libpth.so.20 is needed by dirmngr-1.1.0-4.1.i586
srvM:/srv/www/htdocs # sudo rpm -i libassuan0-2.0.1-4.1.i586.rpm 
error: Failed dependencies:
    libgpg-error.so.0 is needed by libassuan0-2.0.1-4.1.i586
srvM:/srv/www/htdocs # sudo rpm -i libgpg-error0-1.9-4.1.i586.rpm 
    package libgpg-error0-1.9-4.1.i586 is already installed

libgpg-error is already installed but it seems libgpg-error.so.0 is not found, what am I missing?

  • What do you need zypper for on that system? openSUSE 11.4 is out of support. It doesn't get updates anymore. It is so long out of support that you won't be able to do a direct upgrade to a supported version with zypper. If this is a business environment (as your posting in serverfault suggests) the system needs to be reinstalled or replaced anyway. So what's your goal? – Tilman Schmidt May 31 '18 at 11:20
  • In my OpenSuse 11.4 (still working...) /lib64/libgpg-error.so.0 link to the real lib file which is the /lib64/libgpg-error.so.0.7.0 package version look the same: libgpg-error0-1.9-4.1.x86_64 – djv May 31 '18 at 15:39
  • 1
    Thank you for your help, I decided to move to a new server for security reasons. Thank you again for your support! – Niko Zarzani May 31 '18 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.