1

I've been using this image for testing, and for almost every app I've faced this issue, today it's with kubectl. While trying to install it, yum says:

    Retrieving key from https://packages.cloud.google.com/yum/doc/rpm-package-key.gpg
kubernetes/signature                                                                                                                                                                                                  | 1.4 kB  00:00:00 !!!
https://packages.cloud.google.com/yum/repos/kubernetes-el7-x86_64/repodata/repomd.xml: [Errno -1] repomd.xml signature could not be verified for kubernetes
Trying other mirror.

Tried other mirrors, but same result. I'll keep trying, would like to make it work without going to binaries and also know why this happens so often.

Thanks!

1 Answer 1

1

Redhat/Fedora/Centos make use of GPG package signing to ensure that package integrity has not been compromised and to check if the software package comes from authorized sources.

You can import a key into RPM's database by hand using the following command:

rpm --import PUBKEY ...

A remedy for your issue can be to import actual GPG keys from Kubernetes vendor:

 rpm --import https://packages.cloud.google.com/yum/doc/yum-key.gpg

 rpm --import https://packages.cloud.google.com/yum/doc/rpm-package-key.gpg
1
  • Thanks, but didn't work. Have the keys there though: #rpm -q gpg-pubkey --qf '%{name}-%{version}-%{release} --> %{summary}\n' | grep -i google Output: gpg-pubkey-ba07f4fb-5ac168db --> gpg(Google Cloud Packages Automatic Signing Key <gc-team@google.com>) gpg-pubkey-3e1ba8d5-558ab6a8 --> gpg(Google Cloud Packages RPM Signing Key <gc-team@google.com>)
    – Rancor
    Jun 4, 2018 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.