0

I have an issue getting binary logging to work, i gone trough many tips but i see many my.cnf files all over and non seem to take the options needed

/etc/my.cnf
/etc/alternatives/my.cnf
/etc/mysql/my.cnf
/etc/mysql/my.cnf.fallback
/var/lib/dpkg/alternatives/my.cnf


Im running :
Server type: MariaDB Server version: 10.0.34-MariaDB-0ubuntu0.16.04.1 - Ubuntu 16.04

As found on many places the my.cnf needs under [mysqld]

log-bin=bin.log
log-bin-index=bin-log.index
max_binlog_size=100M
binlog_format=row
socket=mysql.sock

After a restart it still this shows

mysql> select variable_value as "BINARY LOGGING STATUS (log-bin) :: "
from information_schema.global_variables where variable_name='log_bin';
+-------------------------------------+
| BINARY LOGGING STATUS (log-bin) :: |
+-------------------------------------+
| OFF |
+-------------------------------------+
1 row in set (0.00 sec)

I tried all files with the options and nothing seems to be taken regarding the binary logging.

Any ideas?

  • 1
    I believe mysqld --verbose --help will give you an indication of which defaults-files the server wants to read... but you might check the error log, because you aren't showing where you set a server_id and that may be required for binary logging. – Michael - sqlbot Jun 3 '18 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.