2

So, Lotus Notes is on its last legs in my organisation and I am the only one supporting it. I am a developer, no admin. I need help.

There is a single domino server that runs a few web applications (no client). There are no domino relay servers. And, emails are to be sent to Outlook 365. So, I set up a Foreign Domain and Connection documents pointing to the destination server.

However, while sending emails, this is the log I get. Note the error message:

SMTPClient: Connection successful
SMTPClient: ReceiveResponse: 220 ****************************************************************************************
SMTPClient: CommandEHLO: EHLO 
SMTPClient: ReceiveResponse: 250-SR31211.ad.domain.com Hello [Domino server IP]
SMTPClient: ReceiveResponse: 250-SIZE 37748736
SMTPClient: ReceiveResponse: 250-PIPELINING
SMTPClient: ReceiveResponse: 250-DSN
SMTPClient: ReceiveResponse: 250-ENHANCEDSTATUSCODES
SMTPClient: ReceiveResponse: 250-STARTTLS
SMTPClient: ReceiveResponse: 250-8BITMIME
SMTPClient: ReceiveResponse: 250-BINARYMIME
SMTPClient: ReceiveResponse: 250 XXXXXXXA
SMTPClient: SMTP Authentication is not required by local server.  Username: -blank-
Router: Transferring mail to domain xx.xx.xx.xx (host xx.xx.xx.xx [xx.xx.xx.xx]) via SMTP
SMTPClient: Attempting to SubmitMessage:
SMTPClient: Error parsing from address <CN=FullName/O=Domain>. Status: 15095.
SMTPClient: Attempting to Disconnect:
SMTPClient: CommandQUIT:
Router: Error transferring message 0025B505 via SMTP to xx.xx.xx.xx OF6D3B769B:20AC268F ON652582A2:0025B505 Invalid Internet address specified.
Router: Message 0025B587 from Fullname/domain state changing to DEAD. Reason: Recipient's Domino Directory entry does not specify a valid Notes mail file
Router: Unable to deliver message 0025B587, 0025B505 to fullname/domain from fullname/domain OFA4B07BC9:E04CAC0B ON652582A2:0025B587
Recipient's Domino Directory entry does not specify a valid Notes mail file

Please note that this functionality used to work a month ago until the destination IP changed. Sender's email (where the error seems to be pointing to) should be picked up from Internet Address specified in the person document which is set correctly. It is confirmed that there are no firewall, authentication or any network issues from the network team's end. So, it is certainly a notes issue.

I don't know what changed.

Any ideas, please help.

1

I am quite sure, that somebody removed the mail- addresses from the person documents in the domino directory probably because they wanted domino to not deliver the mails to the local recipients but to external recipients.

That way the domino senders can not be "translated" in valid internet addresses anymore and you get that message.

You could change the Global Domain document so that it does an automatic conversion of the addresses.

Open the Global Domain Document (Configuration - Messaging - Domains) and change the values on "Conversion" Tab:

Internet address lookup: Disabled <<< This is necessary if there are no more adresses in the nab. Use Enabled if the internet address field is correctly filled.
Local part formed from: Common name
Domino domain(s) included: None

That might help.

  • Thank you for your answer, but before I make any changes you suggested, I would like to understand about mail-addresses in person documents. The Internet Address field in each person document is correctly set. So, should that not suffice? Or, is there any more settings that I should check to ensure that the router is picking up the Internet Address field value only. – Learner Jun 4 '18 at 7:02
  • This SHOULD be enough. Then something else must be wrong... But if there is no Global Domain document at all, then this conversion might not work... – Torsten Link Jun 4 '18 at 7:06
  • I checked, and there is no Global domain document. Is this document necessary? – Learner Jun 4 '18 at 7:12
  • Obviously it is... just create a "dummy" with a dummy- domain. that should solve your problem. – Torsten Link Jun 4 '18 at 7:13
  • Tried creating global domain document. It is still not working and it is still the same error. – Learner Jun 5 '18 at 4:32
1

The issue is resolved. I removed Foreign Domain Document and added the IP in server configuration under Relay host. So, that along with Global Domain Document worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.