0

I have a mysql semi-synchronous replica-set with a master and 2 slaves. The replication happens fine to only one of the nodes but the other node is always stuck with the following status. Slave_IO_State: Waiting for master to send event

Master does not send any data and I see the following in the master mysqld error logs.

2018-05-14T06:43:51.880292Z 113 [ERROR] Semi-sync master failed on
   net_flush() before waiting for slave reply
2018-05-14T06:43:51.880985Z 113 [Note] Stop semi-sync binlog_dump to slave (server_id: 111)
2018-05-14T06:44:41.754052Z 1343 [Note] While initializing dump thread 
   for slave with UUID <770ca92e-5730-11e8-9f7a-000d3a064af1>, found a
   zombie dump thread with the same UUID. Master is killing the zombie 
   dump thread(113).
2018-05-14T06:44:41.863759Z 1343 [Note] Start binlog_dump to 
   master_thread_id(1343) slave_server(111), pos(, 4)
2018-05-14T06:46:11.934785Z 1382 [Note] While initializing dump thread 
   for slave with UUID <770ca92e-5730-11e8-9f7a-000d3a064af1>, found a
   zombie dump thread with the same UUID. Master is killing the zombie 
   dump thread(113).
2018-05-14T06:46:11.934894Z 1382 [Note] Start binlog_dump to
    master_thread_id(1382) slave_server(111), pos(, 4)
2018-05-14T06:47:11.985863Z 1408 [Note] While initializing dump thread 
    for slave with UUID <770ca92e-5730-11e8-9f7a-000d3a064af1>, found a
    zombie dump thread with the same UUID. Master is killing the zombie 
    dump thread(113).

and so on....

my slave_net_timeout is 60 s on the slave and I can clearly see that after every 60 s the slave is trying to reconnect, but the master acknowledges and holds the connection but does not send any data. As a side effect, the number of slave connections to master continuously grows. I also see the following in Show Processlist for the master:

|  113 | repl_user | 172.19.0.12:58174 | NULL | Binlog Dump GTID | 3189 | Waiting to finalize termination | NULL
| 1343 | repl_user | 172.19.0.12:35394 | NULL | Binlog Dump GTID | 418 | starting | NULL |
| 1382 | repl_user | 172.19.0.12:35572 | NULL | Binlog Dump GTID | 328 | starting | NULL |

Any pointers and to debug this further will be greatly appreciated. Thanks!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.