My current setup:

  • I don't have a static IP from my ISP, so I run my own ddns on a Google Cloud instance
  • The ddns I'm running is a docker image from https://github.com/dprandzioch/docker-ddns, and I followed the instructions to configure the Google Cloud DNS
  • The domain foo.dyndns.domain.tld successfully points to my public IP address
  • At home, I have an Asus AC56U router with dnsmasq running on it.
  • dnsmasq points all local.dev requests to my local webserver
  • I've enabled port-forwarding for port 80 to my web-server

My dnsmasq configuration on my AC56U router


My DNS settings in Google Cloud DNS

ns.domain.tld.             A       300   35.xx.xx.xx
dyndns.domain.tld          NS      300   ns.domain.tld

What currently works:

  • All *.local.dev requests, successfully point to my webserver within my LAN network
  • foo.dyndns.domain.tld successfully points to my webserver outside of my LAN ping foo.dyndns.domain.tld returns my public IP.

What I need

  • *.foo.dyndns.domain.tld to point to my webserver outside of my LAN network ping test.foo.dyndns.domain.tld results in Unknown host
  • I'd like it to happen automatically, so without updating NS records for every new project I start working on.

What's the point?

I'm a web- and mobile app developer, and I'd like to allow my clients to access my local dev-server. Unfortunately, my networking experiences are very limited.

What I tried so far

I tried updating my Google Cloud DNS with the following record, but without any success:

*.foo.dyndns.domain.tld    CNAME   300   dyndns.domain.tld

With some trial and error, I finally found the solution:

As described in the tutorial: https://github.com/dprandzioch/docker-ddns on how to set up the DNS, I just had to pass *.foo as the domain parameter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.