0

I am having issues accessing a particular URL from a Windows Server 2012R2. The website is hosted in AWS cloud. The Windows Server from which I am trying to access the URL is Google Cloud Compute Engine hosted in Google Cloud Platform. The URL which I am trying to access is https://api.loginextsolutions.com

The same URL, is accessible from any other computer (from my laptop at home and from office). I haven't tried the URL from another instance in Google Cloud (We only have one instance)

I used Wireshark on the compute instance in Google Cloud. What I can see is it is trying to resend the packets [TCP RETRANSMISSION]

I tried to create a VPC firewall rule to allow all protocols from the IP Addresses corresponding to AWS URL. But, it doesn't help. I am able to access all other websites from the Google Compute instance. I am running out of ideas. Any help is appreciated. Thanks.

  • Were you able to resolve the issue? If so, can you post an answer for the benefit of the community. – Fady Jun 16 '18 at 20:50
0

A ) Try tracert. You will be able to check at what point (hop) the packet drops or times out. Or (when comparing it with a tracert done on a "working" machine).

B ) Simply try a proxy from that machine (socks5 preferably). If it works using a proxy then you know 'something'

C) You could try curl the website using verbose mode and see if you even reach the ssl handshake. If so, it could be the company in question has high security and blocking all old ciphers , or employs any other security measure that IE, on a server OS, which also is outdated, simply does not meet.

They might even have blocked certain ip blocks, that are known to belong to large datacenters for example because their audience unlikely can be coming from a datacenter (like Netflix does, they know traffic from a datacenter is usually a client on vpn trying to break their TOS by getting other regional content. There is no valid use case for datacenter ips, except for the employees having break trying to watch using the company wifi :) )

And there are quite a lot more options but I my hands hurt typing this all on mobile. Good luck!

0

Thank you very much for the suggestions.

We were able to get this issue resolved.

The URL hosting company had actually blocked our IP because too many requests were generated from our Web Application. We later modified the code to fix this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.