0

I have to make sure an old rails 2.3.5 application can support TLS 1.2.

The server currently has openssl 0.9.8 installed, and I understand my first task would be to update openssl to > 1.0.1

The server is running Ubuntu 8.04.3 LTS

I will take a snapshot of the VM before starting, but how risky of a upgrade is this on such a old server?

If I update openssl will it cascade into other required upgrades?

  • 1
    That OS is 5 years past EOL - you might be better off trying to get the application to run on a supported OS instead (maybe by manually installing the required old ruby version there) – HBruijn Jun 7 '18 at 4:55
0

I think it is to risky to update the server. Install new blank server. Than start to migrate your old software and settings.

Don't upgrade your old Ubuntu to the new versions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.