2

Been struggling with this new server for the past month. It's cheap, with no iLO, and seems not to have any support entitlement.

The latest issue is that I need to change from a DVI monitor to a DisplayPort one. The motherboard only has DP outputs, and I've been running with a plug-in DVI card. To check the DP output, I disconnected the drives, and tried booting with:

  1. DP to VGA dongle. This one was shipped with the system, so should presumably work, but doesn't
  2. DP to DVI dongle. The HPE docs are inconsistent about this: some say you need an active dongle, and some don't (I have no idea what this would mean for DVI). Dead
  3. Straight DP cable (both DP to mini-DP, and DP-DP). Dead

Repeated all 3 tests with the DVI card removed from the motherboard, with no change.

I then checked the BIOS (AMI Aptio). This is much less useful than some (Dell, for example), but it does have two relevant settings. I changed the 'onboard graphics' from 'auto' to 'enabled', and tried again, with no change - still no way to get DP.

There's one more setting, to 'skip scaning of external gfx card'. I eventually enabled this, against my better judgement, and the system is now completely bricked - there's no video output at all when I power on.

My immediate problem is that I can't find any way to reverse this change. The manuals say that removing the battery for 10 minutes will clear the NVRAM, but this doesn't seem to be true. I've disconnected all cables from the box, in case one was powering the NVRAM, and had the battery out for 10 minutes, but I still don't get any video from the plug-in DVI card or the DP. So, the 'NVRAM' is presumably actually flash.

I'm tempted to throw the server away and start again. The Gen8 was infinitely better. Any ideas? Maybe a sequence of blind keystrokes that could at least restore the BIOS to default settings? Thanks.

EDIT

Leaving the battery out for an hour makes no difference. I got a friend with a Gen9 to talk me through the lights-out BIOS manual reset, which is (probably, and don't press the keys too quickly):

  1. Press DEL during boot-up, several times
  2. RIGHT 5 times
  3. DOWN 6 times
  4. ENTER (probably twice)
  5. F4
  6. ENTER

I've tried this several times, with and without the DVI card plugged in. The server does re-boot at this point, but still no video, anywhere. Note also that the BIOS screen won't display unless you've got a relatively hi-res monitor attached, which seems pretty dumb for something billed as a server.

I'm going to cut my losses and bin this box, and buy something which isn't HP.

6
  • 1
    If it's a new server, you should have some kind of warranty from your vendor by law.
    – Sven
    Jun 9, 2018 at 8:34
  • Do you have any jumpers on the motherboard? Jun 9, 2018 at 8:52
  • There are various jumpers, and unfitted switches, but no clues on what they're meant to do. Can't find details in the docs, or online, but still looking.
    – EML
    Jun 9, 2018 at 9:43
  • @EML can you make a photo? Jun 9, 2018 at 19:13
  • @MichalSokolowski: what, of the whole motherboard? I design electronics in my day job, and I'm afraid that there's no way I'm going to start jumpering/adding wire links/whatever to a PC motherboard - sorry :) Besides, this is clearly a cost-reduced version of a more complex board - a lot of components (switches/etc) have pads but haven't been assembled.
    – EML
    Jun 10, 2018 at 9:59

2 Answers 2

2

If you remove the battery, short-circuit the 2 connections inside of the battery holder (the HOLDER, NOT the battery itself!) for approximately 10 seconds.

In most cases, this will make sure that the CMOS doesn't get power any more and loses it's content.

1

Try resetting the BIOS via the S6 maintenance switch

Anyway, based on the service manual replacing the battery should have the same effect. Simply try with longer no-battery time (ie: one hour).

2
  • Thanks, but the ML10 v2 motherboard is slightly different from the Gen9 mboard. There are two switches in the general location of S6, but they're not fitted...
    – EML
    Jun 9, 2018 at 9:37
  • The battery removing is effective if all power cords is unplugged. Jun 9, 2018 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .