0

I am a bit trapped between error messages when I install kvm guest systems. Details:

Host system: Debian 9 Guest system: Debian 9 Installation media: **local source* (= downloaded iso file)

I can not see the console output:

root@Debian-94-stretch-64-minimal ~ # virsh console aaa
Connected to domain aaa
Escape character is ^]

... in order to solve this problem, it is recommended to change the boot manager line: "console=ttyS0" needs to be appended to the line beginning with "linux".

But I can do that only once the operating system is installed. For the installer, it is recommended to add a parameter to the install command:

-x 'console=ttyS0'

Unfortunately, it seems to be not possible to install from a local device / iso image and use the -x parameter.

This is my current vm installer command line; I have tried some other versions before:

#!/bin/shvi
virt-install \
  --name aaa \
  --ram 4096 \
  --os-type=linux \
  --os-variant=debian9 \
  --accelerate \
  --disk path=/kvm/aaa/os.img,size=40 \
  --disk /xkvm/debian-9.4.0-amd64-DVD-1.iso,device=cdrom,bus=ide \
  --network bridge=br0 \
  --console pty,target_type=serial \
  -x 'console=tty0' \
  -v

They all either end in:

    root@Debian-94-stretch-64-minimal ~ # virsh console aaa
    Connected to domain aaa
    Escape character is ^]

... or in

ERROR    --extra-args only work if specified with --location. See the man page for examples of using --location with CDROM media

Does anyone know a solution or workaround?

Notes: The local source is important, because my guest vm does not have internet unless I configure it in a special way - and I can only do that after the initial installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.