0

This used to work but no longer seems to. Didn't change anything as far as I know. This is the client .ovpn-file:

push "redirect-gateway def1" client
dev tun
proto udp
remote myip 1194
float
comp-lzo adaptive
keepalive 15 60
auth-user-pass
ns-cert-type server
<ca>
-----BEGIN CERTIFICATE-----
Cerg
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
Cert
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
MY KEY
-----END PRIVATE KEY-----
</key>
resolv-retry infinite
nobind

It all works if I delete the first line with "push" etc. But that is the important part. What am I doing wrong?

  • Have you checked if this server is available? Add verb 3 to config file and start openvpn manually. What does openvpn tell during start? – Krzysztof Sawicki Jun 11 '18 at 10:11
  • Before I tried your changes I tried with this: client dev tun proto udp remote cderdepperte.ddns.net 1194 float comp-lzo adaptive keepalive 15 60 auth-user-pass ns-cert-type server and it seems to be working now. I tried this config before but then my IP wasn't changed, and now it is. Not sure, maybe the router has undergone some updates or changes. Anyhow, it works with these settings. I'm just curious as how my IP is changed without the push "redirect-gateway def1" – djokerndthief Jun 29 '18 at 2:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.