I'd like to install a package named
pA-1.0.0-0depends on package
- On a yum repository, one can find both
pA-1.0.0-0is not compatible with
pB-1.1.0-0, and this information is not mentioned in the RPM of
pB-1.1.0-0did not exist back when
This is a problem when trying to install
$ yum localinstall pA-1.0.0-0.el7.x86_64.rpm ... Resolving Dependencies -> Processing Dependency: pB >= 1.0.0 for package: pA-1.0.0-0.el7.x86_64 --> Package pB.x86_64 0:1.1.0-0.el7 will be installed # <-- version 1.1! ho no!
Is there a command line option in
yum to ask it to install the specific version demanded for its dependencies?
Specifically here, to install
pA-1.0.0-0.el7.x86_64 rather than
Note: I cannot deal with
pA's dependencies by hand: in my real scenario, there is countless dependencies I wouldn't install separately with