So I'm trying to setup a site to site OpenVPN connection from my Google Cloud to my Home/Office network. I used the prebuilt OpenVPN instance provided by Google here and configured it to my needs. I was successfully able to setup a client to server connection and can ping my internal GCP VPC network and even remote into a Windows Server instance, however, my problem is I cannot ping my internal home/office network @ from my internal VPC network @ I can ping my client IP address though...

I have static routes on my VPC that state anything going to to forward out of the OpenVPN access server instance, including anything for my client VPN subnet

I'm trying to do this over a Windows 10 laptop at the moment. I've been following this guide as best I can but it has the client gateway setup as a Linux box. I'd like to do this over a Windows install if at all possible. As I said... as far as I've gotten, the client will connect to the server and resources are available from client to server but I cannot access resources from server to client network.

I know somethings missing but not sure what. Please let me know if I can provide more details.

Below is my running config on my access server.

./confdba -s > config.txt
cat ./config.txt
  "Default": {
    "admin_ui.https.ip_address": "ens4", 
    "admin_ui.https.port": "943", 
    "aui.eula_version": "2", 
    "auth.ldap.0.name": "My LDAP servers", 
    "auth.ldap.0.ssl_verify": "never", 
    "auth.ldap.0.timeout": "4", 
    "auth.ldap.0.use_ssl": "never", 
    "auth.module.type": "local", 
    "auth.pam.0.service": "openvpnas", 
    "auth.radius.0.acct_enable": "false", 
    "auth.radius.0.name": "My Radius servers", 
    "cs.cws_proto_v2": "true", 
    "cs.https.ip_address": "ens4", 
    "cs.https.port": "943", 
    "cs.prof_sign_web": "true", 
    "cs.ssl_method": "SSLv3", 
    "cs.tls_version_min": "1.1", 
    "host.name": "REDACTED", 
    "sa.initial_run_groups.0": "web_group", 
    "sa.initial_run_groups.1": "openvpn_group", 
    "vpn.client.basic": "false", 
    "vpn.client.config_text": "cipher AES-256-CBC\n", 
    "vpn.client.routing.inter_client": "false", 
    "vpn.client.routing.reroute_dns": "false", 
    "vpn.client.routing.reroute_gw": "false", 
    "vpn.client.routing.superuser_c2c_access": "false", 
    "vpn.daemon.0.client.netmask_bits": "24", 
    "vpn.daemon.0.client.network": "", 
    "vpn.daemon.0.listen.ip_address": "ens4", 
    "vpn.daemon.0.listen.port": "443", 
    "vpn.daemon.0.listen.protocol": "tcp", 
    "vpn.daemon.0.server.ip_address": "ens4", 
    "vpn.general.osi_layer": "3", 
    "vpn.server.config_text": "cipher AES-256-CBC\n", 
    "vpn.server.daemon.enable": "true", 
    "vpn.server.daemon.tcp.n_daemons": "1", 
    "vpn.server.daemon.tcp.port": "443", 
    "vpn.server.daemon.udp.n_daemons": "1", 
    "vpn.server.daemon.udp.port": "1194", 
    "vpn.server.duplicate_cn": "true", 
    "vpn.server.nat.masquerade": "true", 
    "vpn.server.port_share.enable": "true", 
    "vpn.server.port_share.ip_address": "", 
    "vpn.server.port_share.port": "1234", 
    "vpn.server.port_share.service": "admin+client", 
    "vpn.server.routing.allow_private_nets_to_clients": "true", 
    "vpn.server.routing.gateway_access": "true", 
    "vpn.server.routing.private_access": "route", 
    "vpn.server.routing.private_network.0": "", 
    "vpn.server.tls_auth": "true", 
    "vpn.server.tls_version_min": "1.2", 
    "vpn.tls_refresh.do_reauth": "true", 
    "vpn.tls_refresh.interval": "360"
  "_INTERNAL": {
    "run_api.active_profile": "Default", 
    "webui.edit_profile": "Default", 
    "webui.welcome_shown": "true"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.