I'm trying to convert a recently updated physical Debian to a virtual machine, but the process halts at 98% giving me an error that I'll include at the end of the post.

From the error I deduced that for some reason the converter expects some modules to be at /lib/ but in reality those modules have been moved to /lib/i386-linux-gnu. I expect this was done by the system when it was updated a few weeks ago and, as I understand it, it was done to better support 32-bit and 64-bit applications.

Now I'd like to ask if there is a way to either make the VMWare Converter Standalone use the right directory, if I can use a symbolic link to connect /lib to /lib/i386-linux-gnu or if it's safe to copy all of the modules inside the new directory to /lib while the conversion process is underway?

[EDIT] I have taken multiple successfull virtual copies of this specific machine before the system update took place.

[EDIT2] Despite the error the converted machine seems to work and the modules can be found from the virtual machine.

[EDIT3] I made a post in VMWares own forums about this problem and they said the problem is that VConverter does not support debian and is mistakenly set as "other linux" in one place. Here is the reply defining the problem:

I've checked the code. There is one place Debian is not recognized as a separate distro; it then is set as 'other linux' which causes the wrong reconfig. This is actually not a bug because Debian is not supported anyway. You mention the vm works. As the wise father said to his son asking "why does the sun shine?" - "if it works, don't touch it" :-) But if you really-really want to tweak it - create a file 'etc/lsb-release', write 'Ubuntu ' and a fictitious version in it (e.g. 16.04) and convert again to see what will happen.

After this I tried to create the /etc/lsb-release file, but that didn't help.

FAILED: An error occurred during the conversion: ' * Looking for deps of module scsi_mod * * Looking for deps of module sd_mod * * Looking for deps of module mptspi * * Looking for deps of module mptscsih * * Looking for deps of module BusLogic * * Looking for deps of module ahci * * Looking for deps of module ide-disk * Cannot find in 4.9.0-6-686-pae module ide-disk * Looking for deps of module pcnet32 * fstab file is /mnt/p2v-src-root/etc/fstab * found root filesystem type as ext3 * Looking for deps of module ext3 * Cannot find in 4.9.0-6-686-pae module ext3 * found root filesystem mount options as errors=remount-ro * processed root filesystem mount options are errors=remount-ro * busybox mount options are * new root will not be mounted as read-only * printing module list: * /mnt/p2v-src-root/lib/modules/4.9.0-6-686-pae/kernel/drivers/scsi/scsi_mod.ko * /mnt/p2v-src-root/lib/modules/4.9.0-6-686-pae/kernel/drivers/scsi/sd_mod.ko * /mnt/p2v-src-root/lib/modules/4.9.0-6-686-pae/kernel/drivers/message/fusion/mptspi.ko * /mnt/p2v-src-root/lib/modules/4.9.0-6-686-pae/kernel/drivers/message/fusion/mptscsih.ko * /mnt/p2v-src-root/lib/modules/4.9.0-6-686-pae/kernel/drivers/scsi/BusLogic.ko * /mnt/p2v-src-root/lib/modules/4.9.0-6-686-pae/kernel/drivers/ata/ahci.ko * /mnt/p2v-src-root/lib/modules/4.9.0-6-686-pae/kernel/drivers/net/ethernet/amd/pcnet32.ko * got lib dir as lib * /mnt/p2v-src-root/lib/libc.so.6 -> /mnt/p2v-src-root/tmp/initrd.ZFby2e/lib * /mnt/p2v-src-root/lib/libm.so.6 -> /mnt/p2v-src-root/tmp/initrd.ZFby2e/lib ERROR: cannot find source file /mnt/p2v-src-root/lib/libm.so.6 during file copy (return code 1)'


I had a similar problem once, and it turned out that I had a folder with hundreds of thousands of small files, and as soon as I packed those files in one zip file and remove the original, it worked.



1- I tried to create symbolic link in /lib64 pointing to /lib/x86_64_linux_gnu/ for each files sudo ln -s /lib/x86_64_linux_gnu/* /lib64/
didn't work

2- I tried to copy all file from /lib/x86_64_linux_gnu/ into /lib64 : the error changed and the missing file was /lib64/ld-linux-x86-64.so.2.

3- Since /lib64/ld-linux-x86-64.so.2 is a symlink i then tried to remove the symlink /lib64/ld-linux-x86-64.so.2 -> /lib/ld-2.24.so to replace it with the real file ld-2.24.so and name it with the symlink name. BUT debian Crashed as soon i remove the symlink, impossible to reboot normally. I had to use a Debian CD and go in rescue mode to put the symlink back to normal (/lib64/ld-linux-x86-64.so.2 -> /lib/ld-2.24.so). After a reboot I was back to where i started, but i didn't want to investigate the problem anymore.

4- Eventhough this error (..98% failed..) seems bad , the Conversion actually manage to create a bootable Virtual Machine which surprisingly seems to run fine. So may be there is no problem.

-- i used Vmware Converter standalone 6.0.0 with a physical machine running Debian 9 (with an apache server) and Vmware ESXi (Vsphere 6).

  • 1
    And perhaps only 98% of your files are on the new virtual machine. – Michael Hampton Sep 6 '18 at 12:33
  • The error seems to appear when the virtual machine is being configured, so at that point the files themselves should be on the machine. At least this is what i found out and described in my [EDIT2], the files are there but the converter can't find them. However, if the files are moved to the other folder (/lib/) from (/lib/i386-linux-gnu) it does find them. – nyoatype Sep 7 '18 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.