1

I have a user in our environment who RDP's into a remote 2008 R2 server in order to use a specific application. When they remote in the first time, the text and icons are all extremely large. This is because the default text scaling on her account is set to 300% by default. When the user changes it back to 100% and logs out, then back in again everything is fine. Except it resets the text scaling back to 300%, so the next time they go to run the application everything is huge again.

Unfortunately you can't change display settings from an RDP session so I'm thinking I'm going to have them log into the vSphere client directly in order to change their display settings.

Is there anyway to fix this just through the RDP session or from her workstation?

0

It's probably because your user is using a high-DPI monitor. Windows can detect that an sends this information to the Remote Desktop Session Host server.

You can disable the scale factor detection and see if that helps:

On the server, add the following registry value:

Key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations

Value (DWORD):
IgnoreClientDesktopScaleFactor 

Data: 1

Then, reboot the server and try to connect again with this user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.